VOGONS

Common searches


DOSBox-X branch

Topic actions

Reply 1980 of 2232, by Wengier

User metadata
Rank Member
Rank
Member

jmarsh: Thanks for pointing out the probable cause of the issue, and you are certainly very familiar with this part of code. If you also know how to actually change this code to fix the said issue please let me know. Thanks a lot!

Reply 1981 of 2232, by gfernval

User metadata
Rank Newbie
Rank
Newbie

Hello:

I have compiled Dosbox-X 0.83.7 for running in Windows XP (SDL2 version) DIAGNOSE.EXE now works, but sound in Windows 3.1 not.
Why both DIAGNOSE.EXE and sound in windows 3.1 work in 0.82.18 but not in newer versions?

Reply 1982 of 2232, by gfernval

User metadata
Rank Newbie
Rank
Newbie

It seems network connection does not work well (worked well in 0.83.6). If you enable network card and
in MS-DOS run:

lsl
ne2000
ipxodi

running ipxodi shows "IPXODI-303-12: The IPX protocol has already been loaded" (when was loaded?)
if I now run "netbios" Dosbox-X 0.83.7 hangs

Reply 1983 of 2232, by gfernval

User metadata
Rank Newbie
Rank
Newbie

Hello:

What about the config settings dosbox-x.conf? in version 0.83.6 the file was 177kb, and in 0.83.7 only 44kb.
In version 0.83.6 you could specify the MAC address of the network card, but in 0.83.7 you can´t.
Ethernet passthrough in 0.83.7 does not work well, after loading lsl.com and ODI ne2000.com, when you are going to
load ipxodi computer says "IPX already loaded", and if you run netbios.exe after ipxodi.com dosbox-x hangs.
Sound does not work in Windows 3.1, time to wait to make a DMA recording fix. Will stay with version 0.83.6 due
to the problems in networking in 0.83.7 version.

Reply 1984 of 2232, by _Rob

User metadata
Rank Member
Rank
Member
gfernval wrote on 2020-11-02, 19:29:
Hello: […]
Show full quote

Hello:

What about the config settings dosbox-x.conf? in version 0.83.6 the file was 177kb, and in 0.83.7 only 44kb.
In version 0.83.6 you could specify the MAC address of the network card, but in 0.83.7 you can´t.
Ethernet passthrough in 0.83.7 does not work well, after loading lsl.com and ODI ne2000.com, when you are going to
load ipxodi computer says "IPX already loaded", and if you run netbios.exe after ipxodi.com dosbox-x hangs.
Sound does not work in Windows 3.1, time to wait to make a DMA recording fix. Will stay with version 0.83.6 due
to the problems in networking in 0.83.7 version.

Regarding the config file, with the latest version there is now a full config file and a partial config file with the more common options. This was meant to be less confusing to the average user as the full config has too may options listed. And you are undoubtedly looking at this partial config. And just because the config does not mention some option, does not mean you cannot add it. Any option not listed will just use the default for that option. You can also generate a full config by typing:
config -wcd -all

Reply 1985 of 2232, by Wengier

User metadata
Rank Member
Rank
Member

gfernval: About the ipxodi issue, I have already fixed it in the latest code. Please check it out.

Regarding the sound, the fix was specifically for DIAGNOSE.EXE. I will check the Win3.1 SB16 driver later.

For the config file, as _Rob already mentioned all config settings are still (and will continue) working, but there are now simply two sample config files, namely dosbox-x.reference.conf (for average users) and dosbox-x.reference.full.conf (for advanced users). Just choose the one you prefer to look at.

Reply 1986 of 2232, by gfernval

User metadata
Rank Newbie
Rank
Newbie

The mingw compiled downloads and DOS compiled downloads are missing, the actual ones for download (Visual C compiled) don´t work in Windows XP. The file dosbox-x.reference.full.conf is not available for download nor inside dosbox-x-vsbuild-win-20201101082314.zip or dosbox-x-windows-0.83.7-setup.exe, but I have recreated it with "config -wcd -all" as _Rob mentioned.
The Latest code is the GitHub code (dosbox-..-master.zip) or dosbox-x-v0.83.7.zip? I have compiled the code inside dosbox-x-v0.83.7 and ipxodi does not work.

thanks

Reply 1987 of 2232, by Wengier

User metadata
Rank Member
Rank
Member

gfernval: Both MinGW builds and DOS packages are now downloadable from:

32-bit MinGW: dosbox-x-mingw-win32-20201103082126.zip

64-bit MinGW: dosbox-x-mingw-win64-20201103091449.zip

DOS package: dosbox-x-mingw-hx-dos-20201103155348.zip

IPXODI should work in the above builds.

For the Visual Studio builds, you must be using an older version of the package. The file dosbox-x-vsbuild-win-20201101082314.zip was already updated yesterday to include the dosbox-x.reference.full.conf file (alongside dosbox-x.reference.conf). The dosbox-x-windows-0.83.7-setup.exe file will install both of them.

The latest code refers to the GitHub code, not dosbox-x-v0.83.7.zip. Unlike the Visual Studio builds which were based on dosbox-x-v0.83.7.zip, the MinGW builds are compiled using the current GitHub code. But the IPXODI fix is the only functional difference between them.

Reply 1988 of 2232, by gfernval

User metadata
Rank Newbie
Rank
Newbie

I have tried to change the following from file dosbox.cpp and compile a new dosbox-x.exe

from:

static void CheckX86ExtensionsSupport()
{
#if defined(__GNUC__) && !defined(EMSCRIPTEN)
sse2_available = __builtin_cpu_supports("sse2");
avx2_available = __builtin_cpu_supports("avx2");
#elif (_MSC_VER) && !defined(EMSCRIPTEN)
Bitu a, b, c, d;
cpuid(1, a, b, c, d);
sse2_available = ((d >> 26) & 1)?true:false;
avx2_available = ((b >> 5) & 1)?true:false;
#endif
}

to:

static void CheckX86ExtensionsSupport()
{
#if defined(__GNUC__) && !defined(EMSCRIPTEN)
sse2_available = false;
avx2_available = false;
#elif (_MSC_VER) && !defined(EMSCRIPTEN)
sse2_available = false;
avx2_available = false;
#endif
}

unfortunately the resultant dosbox-x.exe does not run in Windows XP with Pentium III CPU, it is not as easy to change the above lines

Reply 1993 of 2232, by K.A.R.R.

User metadata
Rank Newbie
Rank
Newbie

hi
i just wanted to report a small bug with dosbox-x.

monkey island enhanced cd version has a problem with cd audio.
audio is playing perfect until u talk to a pirat in the scumm bar.
instead of music u hear only cracks and noise until u leave the bar and the cut scene with le chuck begins.

prob happens with ece r4390 as well.
with normal svn r4390, staging 0.75.2 and with 0.74-3 it plays without the problem.
(i reported this bug in dosbox ece thread aswell
Re: DOSBox ECE (for Windows & Linux) )

btw: nice that dosbox-x has a gui
but it could be a bit more comfortable for e.g. with soundcards.
to change the soundcard for e.g. from sb16 to gus i have to go to configuration tool
disable soundblaster and enable gus
but i also have to set the ultrasnd values and gus dir manually in the dosbox-x.conf file under autoexec
(same with blaster values for sb cards)
would be nice if this is done by dosbox-x automatically when selecting a soundcard in the configuration tool

Reply 1994 of 2232, by cyclone3d

User metadata
Rank l33t++
Rank
l33t++

1993 replies - DOS 6.0 - 6.2:

DOSBOS-X-1993-replies.jpg
Filename
DOSBOS-X-1993-replies.jpg
File size
22.55 KiB
Views
451 views
File license
Public domain

And this is the 1994 th post, the year when DOS 6.21 and 6.22 was released.

Just thought it was kinda interesting and decided to mention it.

Yamaha YMF modified setupds and drivers
Yamaha XG resource repository - updated November 27, 2018
Yamaha YMF7x4 Guide
AW744L II - YMF744 - AOpen Cobra Sound Card - Install SB-Link Header

Reply 1995 of 2232, by Wengier

User metadata
Rank Member
Rank
Member

K.A.R.R.: Thanks for reporting the CD audio issue with Monkey Island CD version! I could confirm the issue and have already fixed it in the latest DOSBox-X code. Thanks kcgen for the fix logic.

I will look at your soundcard setting suggestion later.

Last edited by Wengier on 2020-11-06, 00:59. Edited 1 time in total.

Reply 1996 of 2232, by Wengier

User metadata
Rank Member
Rank
Member

gfernval: I only knew DIAGNOSE.EXE had this issue before, and that is why I specifically fixed it for DIAGNOSE.EXE. If there are more programs with this issue then I can make a different approach before the DMA recording function is properly implemented.

Reply 1998 of 2232, by Wengier

User metadata
Rank Member
Rank
Member
gfernval wrote on 2020-11-06, 19:36:

Windows 3.1 sound does not work. In theory when DMA recording function is properly implemented the sound in all programs will work, right?

Yes. The DMA transfer limit was enforced in earlier versions, and in DOSBox-X 0.83.7 I specifically added an exception for DIAGNOSE.EXE to allow it, which is why DIAGNOSE.EXE works but others (if exist) may not (I can add more exceptions of course). But when DMA recording function is properly implemented all such programs should theoretically work.