Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Discussion about old PC hardware.

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby CuPid » 2019-9-30 @ 08:38

Thanks agent_x007.
Once again an unsupported MSR read is causing the BSOD, I fixed that.

http://download.cpuid.com/betas/cpuz_w95.zip
I need a vacation.

Image
Image
User avatar
CuPid
Newbie
 
Posts: 91
Joined: 2018-2-08 @ 20:42

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby Keatah » 2019-9-30 @ 19:29

Seems any version past v1.81.0 doesn't properly report Core Speed on a Pentium M, stays locked at 1694MHz, when in reality it should range from 600 to 1694 depending on demand. Core VID is also unchanging. Bus Speed and Rated FSB are not even displayed. And of course any info fields for Intel ExtremeGraphics^2 are empty.

But the multiplier is properly displayed, and it changes from 6 through 17 as system demands change.

If you're interested in fixing all this I can provide screenshots or more information.
Keatah
Member
 
Posts: 131
Joined: 2010-7-07 @ 23:55

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby CuPid » 2019-9-30 @ 20:58

Argh yes indeed. I've sent you a PM. Thanks !
I need a vacation.

Image
Image
User avatar
CuPid
Newbie
 
Posts: 91
Joined: 2018-2-08 @ 20:42

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby agent_x007 » 2019-10-01 @ 20:17

CPU-z i7 965.jpg

Awesome job again, thank you :happy:

Q: Will it work on D0 revision as well, or is this C0/C1 only fix ?
Image
User avatar
agent_x007
Oldbie
 
Posts: 1213
Joined: 2016-1-19 @ 11:06

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby CuPid » 2019-10-01 @ 21:13

agent_x007 wrote:Awesome job again, thank you :happy:
Q: Will it work on D0 revision as well, or is this C0/C1 only fix ?


Thanks :happy:
The fix works on all revisions.
I need a vacation.

Image
Image
User avatar
CuPid
Newbie
 
Posts: 91
Joined: 2018-2-08 @ 20:42

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby agent_x007 » 2019-10-06 @ 18:25

Maybe it's for newer CPU-z version, but I have a request/suggestion :
I would like for CPU-z program to show uCode version CPU/MB is using (it could be add on either "CPU" or "Motherboard" tab).
Image
User avatar
agent_x007
Oldbie
 
Posts: 1213
Joined: 2016-1-19 @ 11:06

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby PC@LIVE » 2019-10-08 @ 08:08

Hi, as soon as I can I have to try it on the old PC of my collection, I thought it only worked with win95, instead it works also with W.XP and W.7.
I tried it on my Internet PC:
HP MSI Amethyst-M 1.0 ATi Radeon Xpress 200
AMD Athlon64 X2 3800+
Bestec 300W
Corsair 4GB DDR400
HD WD 40GB SATA
S.O. W.7
I include an image.
Soon I will try on the Pentium Pro 200.
Attachments
cpu-z w95.jpg
AMD 286-16 287-10 4MB HD 45MB VGA 256KB
AMD 386DX-40 Intel 387 8MB HD 81MB VGA 256KB
Cyrix 486DLC-40 IIT387-40 8MB VGA 512KB
AMD 5X86-133 16MB VGA VLB CL5428 2MB and many others
AMD K62+ 550 SOYO 5EMA+ and many others
AST Pentium Pro 200 MHz L2 256KB
User avatar
PC@LIVE
Newbie
 
Posts: 48
Joined: 2019-6-08 @ 15:11
Location: Italy CR

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby PC@LIVE » 2019-10-09 @ 13:30

Bench PentiumPro 200MHz
Attachments
Bench-PP200.jpg
Memory-PP200.jpg
Caches-PP200.jpg
Mainboard-PP200.jpg
CPU-PP200.jpg
AMD 286-16 287-10 4MB HD 45MB VGA 256KB
AMD 386DX-40 Intel 387 8MB HD 81MB VGA 256KB
Cyrix 486DLC-40 IIT387-40 8MB VGA 512KB
AMD 5X86-133 16MB VGA VLB CL5428 2MB and many others
AMD K62+ 550 SOYO 5EMA+ and many others
AST Pentium Pro 200 MHz L2 256KB
User avatar
PC@LIVE
Newbie
 
Posts: 48
Joined: 2019-6-08 @ 15:11
Location: Italy CR

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby CuPid » 2019-10-10 @ 07:37

Thanks PC@LIVE.

agent_x007 : the microcode version is reported on modern CPUs, but not in the gui, only in the report.
I need a vacation.

Image
Image
User avatar
CuPid
Newbie
 
Posts: 91
Joined: 2018-2-08 @ 20:42

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby DosFreak » 2019-10-27 @ 02:30

Noticed this today:
http://www.os2museum.com/wp/more-about- ... pentium-4/

A few years ago I wrote about a strange NetBurst processor with SL7HY S-spec that landed at the OS/2 Museum. After renewed reader interest I pulled it out of the closet and tested the processor again. A collection of miscellaneous notes follows.

CPU-Z today is just as clueless as it was a few years ago (no surprise), thinking it’s a Socket 604 processor and that it’s an engineering sample:
User avatar
DosFreak
l33t++
 
Posts: 10552
Joined: 2002-6-30 @ 16:35
Location: Your Head

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby aka286dos » 2019-11-23 @ 09:08

If it's of interest. I get a BSOD with MD5 (cpuz_w9x.exe) = 0c391b3bd686147c602c6afe4429361f:

A fatal exception 0D has occurred at 0028:C1BB31C6 in VXD CVXDSAMP(01) + 000001C6.


Windows 98SE on one of these: https://www.parkytowers.me.uk/thin/hp/t5710/
User avatar
aka286dos
Newbie
 
Posts: 14
Joined: 2008-2-12 @ 11:04

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby CuPid » 2019-11-23 @ 18:49

@DosFreak : Thanks. ES detection is pretty straightforward tho, I guess some CPUs are wrongly marked.

@aka286dos : Thanks for the report, I'll try to fix that and will let you know.
I need a vacation.

Image
Image
User avatar
CuPid
Newbie
 
Posts: 91
Joined: 2018-2-08 @ 20:42

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby CuPid » 2019-11-27 @ 22:55

"CPU-Z Vintage Edition" is now publically available :
https://www.cpuid.com/news/66-cpu-z-vintage-edition.html

The validation works (cvf and online), and the pages are specific to that version (not visually yet), with a special forum banner (there are some examples in my signature).

Once again I thank you all for your help so far.
I need a vacation.

Image
Image
User avatar
CuPid
Newbie
 
Posts: 91
Joined: 2018-2-08 @ 20:42

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby PiotrUU » 2019-12-05 @ 09:18

Hi,

Ti486sxl PGA168 + ULSI FPU @ exp4349
Attachments
v4.jpg
IMG_20191204_202413.jpg
v1.jpg
PiotrUU
Newbie
 
Posts: 6
Joined: 2019-1-13 @ 14:13
Location: Poland

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby CuPid » 2019-12-06 @ 13:29

Thanks PiotrUU. I've improved things to make the detection of the SXL better, can you please give it a try and let me know ?

http://download.cpuid.com/betas/cpuz_w95.zip

Thanks :happy:
I need a vacation.

Image
Image
User avatar
CuPid
Newbie
 
Posts: 91
Joined: 2018-2-08 @ 20:42

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby PiotrUU » 2019-12-06 @ 22:34

I did some tests. Win95 did not work with cx486s (M5) and cx486dx (M6) on exp4349 !!
WIN95 with CPU cx486dx2 (M7) works.
I send results via email.
Attachments
v5_b.jpg
IMG_20191206_183136.jpg
v5_a.jpg
IMG_20191206_181611.jpg
v5_e.jpg
PiotrUU
Newbie
 
Posts: 6
Joined: 2019-1-13 @ 14:13
Location: Poland

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby CuPid » 2019-12-07 @ 17:37

Thank you PiotrUU.

It is indeed strange that the DX2 works and not the DX nor the S. Are you use that they are working ?

The SXL is detected as a DLC with a 16-KByte L1 :dead:. The cache detection routine is wrong because it is designed to detect 4-way caches, and I think the SXL uses a 8-KByte 2-way cache.
Anyway, that version should work OK on the SXL.
http://download.cpuid.com/betas/cpuz_w95.zip

Also, the validation should work too, another problem was fixed on that side.
I need a vacation.

Image
Image
User avatar
CuPid
Newbie
 
Posts: 91
Joined: 2018-2-08 @ 20:42

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby PiotrUU » 2019-12-08 @ 22:04

Ti486sxl :-)
Greetings !
Attachments
ti486sxl.jpg
PiotrUU
Newbie
 
Posts: 6
Joined: 2019-1-13 @ 14:13
Location: Poland

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby CuPid » 2019-12-09 @ 11:51

Great ! Thanks PiotrUU.
I need a vacation.

Image
Image
User avatar
CuPid
Newbie
 
Posts: 91
Joined: 2018-2-08 @ 20:42

Re: Need help to improve the support of 486/586/686 class CPUs in CPU-Z

Postby Carlos S. M. » 2019-12-09 @ 12:06

Tried CPU-Z Vintage Edition on NT 3.51 (running on a VM) with SP5, some updates and VC++ 6.0 libraries, throws an error about a missing function about OS version, but starts.

Will try some older hardware later on 9x or NT 4.

VirtualBoxVM_Sg6e4XfETl.png
main window

VirtualBoxVM_9saoL90qsH.png
bench

VirtualBoxVM_by0PeDysKl.png
About window


Edit: errors found
VirtualBoxVM_DlvRtaWYnB.png
first error
VirtualBoxVM_DlvRtaWYnB.png (6.08 KiB) Viewed 16 times

VirtualBoxVM_sZKRqexh36.png
second error
Carlos S. M.
Oldbie
 
Posts: 696
Joined: 2016-5-25 @ 17:01
Location: Canary Islands, Spain

PreviousNext

Return to General Old Hardware

Who is online

Users browsing this forum: Backfire_67, Big Pink, dionb, Google [Bot], MSN [Bot], stamasd and 17 guests