VOGONS


soundblaster awe 32

Topic actions

First post, by scroeffie

User metadata
Rank Member
Rank
Member

iam building a 286 almost finished last thing to install is a soundcard
its a ct3900 awe32 i got the drivers from phils website not shure if they are correct but the install stops half way
i did run diagnose and i can hear the sound and voice testing 8bit and 16 bit
after that iam not shure what to do ,a friend told me the card wont work on a 286 because of timing ?? and the drivers wil freeze the pc when you reboot
any help please thanks i also dont understand the difrence between pnp and non pnp ? both cards need drivers ??

Attachments

  • 3.jpg
    Filename
    3.jpg
    File size
    288.65 KiB
    Views
    613 views
    File license
    CC-BY-4.0
  • 2.jpg
    Filename
    2.jpg
    File size
    215.06 KiB
    Views
    613 views
    File license
    CC-BY-4.0
  • 1.jpg
    Filename
    1.jpg
    File size
    238.29 KiB
    Views
    613 views
    File license
    CC-BY-4.0

Reply 1 of 42, by Disruptor

User metadata
Rank Oldbie
Rank
Oldbie

No, that's wrong. As long as you can run the initialisazion tools plus AWEUTIlL.EXE you should be able to hear sound.
You need AWEUTIL because the OPL3 / FM synthesis may be routed through the AWE chip.
Just try it and write about your results.

Perhaps you have problems with the Plug and Play configuration utility CTCM on a 286.
What's with Intel ICU? What's with unisound?

Reply 2 of 42, by Gmlb256

User metadata
Rank Oldbie
Rank
Oldbie
Disruptor wrote on 2022-05-15, 13:29:

Perhaps you have problems with the Plug and Play configuration utility CTCM on a 286.
What's with Intel ICU? What's with unisound?

That AWE32 revision isn't PnP, but UNISOUND can be used to initialize it instead of DIAGNOSE. and AWEUTIL

Reply 4 of 42, by Gmlb256

User metadata
Rank Oldbie
Rank
Oldbie

No. Normally you would need to initialize the AWE32 CT3900 like this in AUTOEXEC.BAT:

SET BLASTER=A220 I5 D1 H5 P330 E620 T6
SET SOUND=C:\SB16
C:\SB16\DIAGNOSE /S
C:\SB16\AWEUTIL /S /R:0 /C:0
C:\SB16\MIXERSET /P /Q

Assuming that all the software are located at C:\SB16.

Reply 7 of 42, by scroeffie

User metadata
Rank Member
Rank
Member

the driver wont finish the install i think its the wrong driver ,but i tested the card in diagnose and i have sound ,config and auto files are empty just bluescreen not shure why

maybe i need to delete eveything and start over

Reply 9 of 42, by Gmlb256

User metadata
Rank Oldbie
Rank
Oldbie

I think that you are better off with UNISOUND to initialize that sound card on a 286 computer.

If you decided to download it and transfer the COM executable that is inside the zip file into the root of the C drive on the 286 computer, add the following lines into AUTOEXEC.BAT:

SET BLASTER=A220 I5 D1 H5 P330 E620 T6
UNISOUND /CS

It is much simpler and I added the /CS command line switch because your AWE32 isn't a PnP card.

Reply 11 of 42, by Gmlb256

User metadata
Rank Oldbie
Rank
Oldbie
scroeffie wrote on 2022-05-15, 17:15:

Wrong drivers for that AWE32 sound card indeed, the correct ones shouldn't install CTCM.

Last edited by Gmlb256 on 2022-05-15, 17:23. Edited 1 time in total.

Reply 13 of 42, by scroeffie

User metadata
Rank Member
Rank
Member

nothing is happening i deleted dos and resintalled dos than the com file buts its a com file its does nothing ?

Attachments

  • 1.jpg
    Filename
    1.jpg
    File size
    156.95 KiB
    Views
    452 views
    File license
    CC-BY-4.0

Reply 14 of 42, by dormcat

User metadata
Rank Member
Rank
Member
scroeffie wrote on 2022-05-15, 18:03:

nothing is happening i deleted dos and resintalled dos than the com file buts its a com file its does nothing ?

May I ask

  1. Have you ever used MS-DOS before? Do you know how AUTOEXEC.BAT and CONFIG.SYS work?
  2. What is your native language?
  3. How old are you?

You've been active on VOGONS longer that I have. Four years would be more than enough to get a hold on some basic MS-DOS knowledge.

Reply 15 of 42, by Gmlb256

User metadata
Rank Oldbie
Rank
Oldbie
scroeffie wrote on 2022-05-15, 18:03:

nothing is happening i deleted dos and resintalled dos than the com file buts its a com file its does nothing ?

Only remove both 1 and 2 from each line in AUTOEXEC.BAT. 🤦

dormcat wrote on 2022-05-15, 18:09:
May I ask […]
Show full quote
scroeffie wrote on 2022-05-15, 18:03:

nothing is happening i deleted dos and resintalled dos than the com file buts its a com file its does nothing ?

May I ask

  1. Have you ever used MS-DOS before? Do you know how AUTOEXEC.BAT and CONFIG.SYS work?
  2. What is your native language?
  3. How old are you?

weedeewee and I had some trouble explaining the details to him on a different thread.

Last edited by Gmlb256 on 2022-05-15, 18:39. Edited 2 times in total.

Reply 16 of 42, by scroeffie

User metadata
Rank Member
Rank
Member

yes i have been using ms dos sins i was a kid ,but i forget fast and iam autistic and have dislexia ,iam 40
native language is dutch ,iam not good at reading and when i read i need time to process what i read 😀 if that makes sense
wil try again to install it but not shure how to install a com file ? where is the exe file ?

Reply 17 of 42, by dormcat

User metadata
Rank Member
Rank
Member
scroeffie wrote on 2022-05-15, 18:18:

yes i have been using ms dos sins i was a kid ,but i forget fast and iam autistic and have dislexia ,iam 40
native language is dutch ,iam not good at reading and when i read i need time to process what i read 😀 if that makes sense
wil try again to install it but not shure how to install a com file ? where is the exe file ?

Okay, I understand you have difficulties, but you have to know the basics of how MS-DOS and its key system files work. You "deleted dos and resintalled dos" but that wouldn't help.

And I wouldn't recommend installing AWE32 on a 286. System requirements provided by Creative Labs required 486 with 4MB RAM minimum; while it's possible to install the card on an older system, it would be similar to testing the minimal memory requirement of Windows:

tdnc.jpg
Filename
tdnc.jpg
File size
188.71 KiB
Views
417 views
File license
CC-BY-4.0

Taken from https://www.youtube.com/watch?v=i9VFikWw44g

Reply 18 of 42, by scroeffie

User metadata
Rank Member
Rank
Member

stil no sound how do install the com file ? what am i doing wrong

Attachments

  • 2.jpg
    Filename
    2.jpg
    File size
    589.73 KiB
    Views
    409 views
    File license
    CC-BY-4.0
  • 1.jpg
    Filename
    1.jpg
    File size
    788.41 KiB
    Views
    409 views
    File license
    CC-BY-4.0

Reply 19 of 42, by dormcat

User metadata
Rank Member
Rank
Member
scroeffie wrote on 2022-05-15, 18:58:

stil no sound how do install the com file ? what am i doing wrong

You have to edit your existing AUTOEXEC.BAT file, not creating a new AUTOEXEC without .BAT extension.