VOGONS


Reply 20 of 34, by Matth79

User metadata
Rank Oldbie
Rank
Oldbie

Currently looking at a similar choice issue - on a P133
Choices being - for a DOS + Win98 setup
1. The built-in S3 Trio 64 (no 3D but good DOS compatibility)
2. Matrox millennium 2 - not sure how far it goes in D3D, but wouldn't run what I wanted in 98
3. S3 Savage 4 - the card I was going to use, but thought it had died (actually just didn't agree with the monitor) - DX6 capable I believe, and I think it did run "Got some Balls"
4. Geforce FX5200 (Quadro NVS280) - DX9 but weak
So interested in the "best drivers" issue, as I'd usually plump for the latest available

Reply 21 of 34, by swaaye

User metadata
Rank Moderator
Rank
Moderator

A P133 is quite slow for any 3D accelerated games so I would only look at things from a DOS and Windows 2D standpoint. Any of those cards will be solid for that. The Trio 64 is typical of what you'd see with a P133 and it would bring excellent compatibility. The other cards have more speed potential but the P133 is the bottleneck. A P133 is really at best a 640x480 DOS / Windows game CPU.

Reply 22 of 34, by swaaye

User metadata
Rank Moderator
Rank
Moderator
ReadySelectStart wrote on 2021-07-15, 22:24:
Sorry to spam, just an update in case anyone stumbles upon this: 61.76 was the issue for the corruption and glitching in 3DMark9 […]
Show full quote

Sorry to spam, just an update in case anyone stumbles upon this: 61.76 was the issue for the corruption and glitching in 3DMark99. 56.64 ran super smooth with no issues.

Scores now are:
3DMARK99: 4811 / 12087
3DMARK2001: 4353

I did occasionally hear the fan on the card ramp up and down so new thermal paste and general tlc is probably needed too.

In terms of using a driver such as 45.23, will this be stable especially with this card having 256MB of RAM rather than the 5200's 128MB?

When I did this hack on the 5700 either making it the 5200 or 5900, the system was unstable and there was corruption and glitches everywhere even on the desktop. Though the 5700LE apparently is an outlier in the line up and should be avoided it seems

You should let us know if it works. 😉 256MB cards do work with 45.23. You could also try 43.45 or 44.03.

Don't get too obsessed with 3DMark scores. NVidia was "optimizing" their drivers like crazy in those days to get more speed by reducing image quality and detecting popular software (ie 3DMark).

I would only consider newer drivers if you want to play a game that is newer than the 4x.xx series. 45.23 is from March 2003. Another reason could be something like the excellent Zeckensack Glide wrapper which was updated through 2005 and might benefit from a newer driver. GeForce FX is a nice match for that wrapper by the way thanks to their hardware support for palettized textures.

Last edited by swaaye on 2021-07-16, 05:54. Edited 1 time in total.

Reply 23 of 34, by RandomStranger

User metadata
Rank Member
Rank
Member
Joseph_Joestar wrote on 2021-07-12, 12:32:

The MX460 is a perfectly fine card for Win9x gaming. This includes most 2001 games, unless you want to play them at resolutions above 1280x1024 with AA and AF fully maxed out.

I'm not sure if the 5200 would be faster than the MX460. Maybe if it's the 128-bit version? In any case, both the MX460 and the 5200 will work with 45.23 drivers.

The MX460 is really one of the best budget option. The FX5200 is definitely slower with less stable frame rate. Even if it's the 128bit version in my experience. Maybe if it has decent memory clocks AND 128bit, but I couldn't test a version like that yet.

sreq.png

Reply 24 of 34, by ReadySelectStart

User metadata
Rank Newbie
Rank
Newbie
swaaye wrote on 2021-07-16, 05:29:
You should let us know if it works. ;) 256MB cards do work with 45.23. You could also try 43.45 or 44.03. […]
Show full quote
ReadySelectStart wrote on 2021-07-15, 22:24:
Sorry to spam, just an update in case anyone stumbles upon this: 61.76 was the issue for the corruption and glitching in 3DMark9 […]
Show full quote

Sorry to spam, just an update in case anyone stumbles upon this: 61.76 was the issue for the corruption and glitching in 3DMark99. 56.64 ran super smooth with no issues.

Scores now are:
3DMARK99: 4811 / 12087
3DMARK2001: 4353

I did occasionally hear the fan on the card ramp up and down so new thermal paste and general tlc is probably needed too.

In terms of using a driver such as 45.23, will this be stable especially with this card having 256MB of RAM rather than the 5200's 128MB?

When I did this hack on the 5700 either making it the 5200 or 5900, the system was unstable and there was corruption and glitches everywhere even on the desktop. Though the 5700LE apparently is an outlier in the line up and should be avoided it seems

You should let us know if it works. 😉 256MB cards do work with 45.23. You could also try 43.45 or 44.03.

Don't get too obsessed with 3DMark scores. NVidia was "optimizing" their drivers like crazy in those days to get more speed by reducing image quality and detecting popular software (ie 3DMark).

I would only consider newer drivers if you want to play a game that is newer than the 4x.xx series. 45.23 is from March 2003. Another reason could be something like the excellent Zeckensack Glide wrapper which was updated through 2005 and might benefit from a newer driver. GeForce FX is a nice match for that wrapper by the way thanks to their hardware support for palettized textures.

I tried it with 45.23 and seems to have taken without issue.

The results:

56.64:
3DMARK99: 4811
3DMARK2001: 4353
Quake 3: 95.1

45.23 selecting FX5200:
3DMARK99: 5462
3DMARK2001: 4347
Quake 3: 94.8

I'll have to try running more benchmarks to see the difference more.

Reply 25 of 34, by AlexZ

User metadata
Rank Newbie
Rank
Newbie
Matth79 wrote on 2021-07-16, 00:45:
Currently looking at a similar choice issue - on a P133 Choices being - for a DOS + Win98 setup 1. The built-in S3 Trio 64 (no 3 […]
Show full quote

Currently looking at a similar choice issue - on a P133
Choices being - for a DOS + Win98 setup
1. The built-in S3 Trio 64 (no 3D but good DOS compatibility)
2. Matrox millennium 2 - not sure how far it goes in D3D, but wouldn't run what I wanted in 98
3. S3 Savage 4 - the card I was going to use, but thought it had died (actually just didn't agree with the monitor) - DX6 capable I believe, and I think it did run "Got some Balls"
4. Geforce FX5200 (Quadro NVS280) - DX9 but weak
So interested in the "best drivers" issue, as I'd usually plump for the latest available

I would pick Savage 4 out of curiosity. Geforce FX5200 makes sense for Pentium II or III. Savage 4 was supposed to have usable 3D performance unlike Trio 64 or Virge DX/2. You should get the same compatibility in DOS as with Trio 64.

Pentium III 600E, ECS P6BXT-A+, 384MB RAM, NVIDIA GeForce FX 5600 128MB, 80GB HDD, Yamaha SM718 ISA, 19" AOC 9GlrA
Athlon 64 3400+, MSI K8T Neo V, 1GB RAM, NVIDIA GeForce 7600GT 256MB, 250GB HDD, Sound Blaster Audigy 2 ZS

Reply 26 of 34, by ReadySelectStart

User metadata
Rank Newbie
Rank
Newbie

Okay, I performed some more benchmarks. I also added more RAM as someone suggested and took note to see how that impacted performance. Not the most comprehensive benchmarking but hopefully gives an idea:

FX5500, 128MB RAM, 61.76:

3DBench 1.0c - 306.1
Chris' 3D Bench (640x480) - 138.9
PC Player (640x480) - 31.1
Doom - 111.97
Quake (360x480) - 58.7
Quake (640x480) - 51.1
Quake III Timedemo - 95.1
3DMark99 - 4790
3DMark01 - 4326

FX5500 as 5200, 128MB RAM, 45.23:

3DBench 1.0c - 297.9
Chris' 3D Bench (640x480) - Failed
PC Player (640x480) - 30.4
Doom - 110.47
Quake (360x480) - 57.6
Quake (640x480) - 21.2
Quake III Timedemo - 94.8
3DMark99 - 5462
3DMark01 - 4347

FX5500 as 5200, 640MB RAM, 45.23:

3DBench 1.0c - 297.9
Chris' 3D Bench (640x480) - Failed
PC Player (640x480) - 30.4
Doom - 108.08
Quake (360x480) - 57.3
Quake (640x480) - 20
Quake III Timedemo - 97.6
3DMark99 - 5956
3DMark01 - 4419

MX440, 128MB RAM, 45.23:

3DBench 1.0c - 190.3
Chris' 3D Bench (640x480) - Failed
PC Player (640x480) - 30.3
Doom - 70.5
Quake (360x480) - 47.4
Quake (640x480) - 30
Quake III Timedemo - 98.8
3DMark99 - 5183
3DMark01 - 2416

MX440, 640MB RAM, 45.23:

3DBench 1.0c - 415.9
Chris' 3D Bench (640x480) - Failed
PC Player (640x480) - 30.3
Doom - 70.6
Quake (360x480) - 47.5
Quake (640x480) - 20
Quake III Timedemo - 101.8
3DMark99 - 6208
3DMark01 - 3051

MX460, 128MB RAM, 45.23:

3DBench 1.0c - 297.9
Chris' 3D Bench (640x480) - Failed
PC Player (640x480) - 30.5
Doom - 108.08
Quake (360x480) - 57.2
Quake (640x480) - 20.1
Quake III Timedemo - 99.3
3DMark99 - 6540
3DMark01 - 3655

(Just to clarify, other than Quake III and 3DMark, the above was all done in a DOS boot not from command line/prompt in Windows)

Last edited by ReadySelectStart on 2021-07-22, 19:58. Edited 1 time in total.

Reply 28 of 34, by ReadySelectStart

User metadata
Rank Newbie
Rank
Newbie
Putas wrote on 2021-07-19, 12:16:

Some wild fluctuations in there.

Especially with Quake at 640x480. I did not expect to see 20fps. Also surprised how much of a difference system RAM made to some of the tests

Reply 29 of 34, by Joseph_Joestar

User metadata
Rank Oldbie
Rank
Oldbie

Assuming you're running original Quake for DOS, and not WinQuake or GLQuake, you want to do the following to get proper benchmark results:

  1. Patch the game to v1.08
  2. Only benchmark under pure DOS i.e. not while Windows is running
  3. Benchmark only using standard resolutions such as 320x200 and 640x480
  4. Run FASTVID before performing the tests
  5. Disable VSync by editing Quake's config.cfg and setting these entries to zero:
    vid_wait "0"
    _vid_wait_override "0"

That should give you more consistent results. Also, don't use more than 512 MB RAM on Win98SE. It will cause all sorts of problems.

PC#1: Pentium MMX 166 / Soyo SY-5BT / S3 VirgeDX / Voodoo1 / OPTi 82C930 / AWE64
PC#2: Celeron 466 / Abit ZM6 / Voodoo3 / AWE64 / YMF744 / SC-155
PC#3: AthlonXP 1700+ / Abit KT7A / GeForce4 / SBLive / ALS100
PC#4: Athlon64 3700+ / DFI LanParty / 9600GT / X-Fi Titanium

Reply 30 of 34, by ReadySelectStart

User metadata
Rank Newbie
Rank
Newbie
Joseph_Joestar wrote on 2021-07-19, 12:56:
Assuming you're running original Quake for DOS, and not WinQuake or GLQuake, you want to do the following to get proper benchmar […]
Show full quote

Assuming you're running original Quake for DOS, and not WinQuake or GLQuake, you want to do the following to get proper benchmark results:

  1. Patch the game to v1.08
  2. Only benchmark under pure DOS i.e. not while Windows is running
  3. Benchmark only using standard resolutions such as 320x200 and 640x480
  4. Run FASTVID before performing the tests
  5. Disable VSync by editing Quake's config.cfg and setting these entries to zero:
    vid_wait "0"
    _vid_wait_override "0"

That should give you more consistent results. Also, don't use more than 512 MB RAM on Win98SE. It will cause all sorts of problems.

I used Phil's Dosbench tool in DOS for the Quake benchmarks. I'll remove the 128MB stick of RAM and test again

Last edited by ReadySelectStart on 2021-07-22, 19:56. Edited 1 time in total.

Reply 31 of 34, by zyga64

User metadata
Rank Member
Rank
Member

As Joseph_Joestar said, tests from Phil's Dosbench should be started in plain DOS mode (not in Windows 9x DOS box). To get speed boost you should run FASTVID before.
Although windows video drivers are doing same/similiar thing as FASTVID, Windows itself can cause slowdowns.

Check if your VIA based motherboard have "4-way memory interleave" option in BIOS. It should be enabled.
If there is no such option in BIOS, feature may be enabled by default. You can check it in SiSoft Sandra.
If Sandra shows no interleave, you can use Via Interleave memory enabler.
You can achive quite a big speed boost (in Windows) this way.
Direct link: https://soggi.org/files/misc/tools/Memory-Int … Enabler_0.15.7z

1) VLSI SCAMP /286@20 /4MB /TVGA9000C /CMI8330
2) i420EX /486DX33 /16MB /TGUI9440 /YMF718+GUS
3) i430HX /P233MMX /64MB /VirgeDX+3DFX /AWE32
4) i440BX /P !!! 750 /256MB /GF4MX440 /SBLive!+Vibra16s
5) i865G /E5800 /2GB /Ti4200 /YMF724

Reply 32 of 34, by ReadySelectStart

User metadata
Rank Newbie
Rank
Newbie
zyga64 wrote on 2021-07-20, 05:57:
As Joseph_Joestar said, tests from Phil's Dosbench should be started in plain DOS mode (not in Windows 9x DOS box). To get speed […]
Show full quote

As Joseph_Joestar said, tests from Phil's Dosbench should be started in plain DOS mode (not in Windows 9x DOS box). To get speed boost you should run FASTVID before.
Although windows video drivers are doing same/similiar thing as FASTVID, Windows itself can cause slowdowns.

Check if your VIA based motherboard have "4-way memory interleave" option in BIOS. It should be enabled.
If there is no such option in BIOS, feature may be enabled by default. You can check it in SiSoft Sandra.
If Sandra shows no interleave, you can use Via Interleave memory enabler.
You can achive quite a big speed boost (in Windows) this way.
Direct link: https://soggi.org/files/misc/tools/Memory-Int … Enabler_0.15.7z

It was in pure DOS mode. I don't touch DOS under Windows if I can help it

Reply 33 of 34, by dormcat

User metadata
Rank Newbie
Rank
Newbie
Matth79 wrote on 2021-07-16, 00:45:
Currently looking at a similar choice issue - on a P133 Choices being - for a DOS + Win98 setup 1. The built-in S3 Trio 64 (no 3 […]
Show full quote

Currently looking at a similar choice issue - on a P133
Choices being - for a DOS + Win98 setup
1. The built-in S3 Trio 64 (no 3D but good DOS compatibility)
2. Matrox millennium 2 - not sure how far it goes in D3D, but wouldn't run what I wanted in 98
3. S3 Savage 4 - the card I was going to use, but thought it had died (actually just didn't agree with the monitor) - DX6 capable I believe, and I think it did run "Got some Balls"
4. Geforce FX5200 (Quadro NVS280) - DX9 but weak
So interested in the "best drivers" issue, as I'd usually plump for the latest available

Savage4 is just as compatible as Trio64 and faster in every way; I've been using a Savage4 Pro on my Pentium-MMX 233 for DOS, Windows 3.1 (yes it has dedicated Windows 3.1 drivers), and Windows 98SE.

On the other hand, very few 3D-accelerated games work under Pentium 133; the minimum system requirements usually want MMX 166 or faster CPU.

Reply 34 of 34, by Matth79

User metadata
Rank Oldbie
Rank
Oldbie
dormcat wrote on 2021-07-22, 20:42:
Matth79 wrote on 2021-07-16, 00:45:
Currently looking at a similar choice issue - on a P133 Choices being - for a DOS + Win98 setup 1. The built-in S3 Trio 64 (no 3 […]
Show full quote

Currently looking at a similar choice issue - on a P133
Choices being - for a DOS + Win98 setup
1. The built-in S3 Trio 64 (no 3D but good DOS compatibility)
2. Matrox millennium 2 - not sure how far it goes in D3D, but wouldn't run what I wanted in 98
3. S3 Savage 4 - the card I was going to use, but thought it had died (actually just didn't agree with the monitor) - DX6 capable I believe, and I think it did run "Got some Balls"
4. Geforce FX5200 (Quadro NVS280) - DX9 but weak
So interested in the "best drivers" issue, as I'd usually plump for the latest available

Savage4 is just as compatible as Trio64 and faster in every way; I've been using a Savage4 Pro on my Pentium-MMX 233 for DOS, Windows 3.1 (yes it has dedicated Windows 3.1 drivers), and Windows 98SE.

On the other hand, very few 3D-accelerated games work under Pentium 133; the minimum system requirements usually want MMX 166 or faster CPU.

Leaning toward the Savage 4 - I have a recollection that it did run "I've got some balls" with my old Cyrix 6x86 - just trying to think if I have any better PCI only systems to put the FX5200 in apart from perhaps putting the S423 back together that I used as a case donor, Hmm, I like... needs some DDR - I don't like, must see what insane price that's going for