VOGONS

Common searches


First post, by myne

User metadata
Rank Member
Rank
Member

Hey all,

Got bored, and like most bored people I decided to play with a 30 year old obsolete OS.

Basically I made an auto-install iso which automatically does the following:
1) Installs dos (tested with 6.22)
2) Installs Win3.11 + TCPIP + VMware's virtual AMD network card
3) Installs Soundblaster 16 drivers
4) Has the option to run a modified and a bit problematic modified svga driver (google for info about the patch).

How to use.
Copyright dictates that it's not a complete iso. It's a template you'll have to fill with your own presumably licenced files.
I suggest using ultraiso to:
1) Copy the contents of your dos floppies into the dos622 folder
2) Copy the contents of your win311 floppies into the win311 folder BUT DO NOT OVERWRITE ANY EXISTING FILES
3) Save/burn
4) Install (<5min - most of the time is taken up by the cdrom driver loading every reboot (~5). True story.)

Installation process.
Most of the time it's just hitting enter when required. There's one expected error where you have to press A. It's noted.
Once you're in windows, try the modded display driver, reboot a few times if it hangs and see if it starts working.

Notes
1) This was built with vmware player and is therefore built around whatever quirks it may have.
2) It should still work on real hardware because it doesn't modify anything important
3) The setup kinda assumes the drive won't be formatted at all. It will do the fdisk stuff and continue. It MAY work on a formatted drive. See #1
4) The modified svga driver is called SVGB256.drv. It shows in the standard "change video" area of the setup as "0 VMWARE Patched SVGA 1024x768x256". It is renamed so it doesn't interfere with the original SVGA256.drv or it's settings (ie so the iso can work on real hardware too)
5) The modded svga driver WILL disable filesharing. I found that little tip when I was wondering why it's so glitchy. It may... just freeze sometimes on boot. Not sure if that's the driver or just vmware. It worked after a few reboots on mine. It will glitch out if you use a dos window. Don't.
6) If the svga driver glitches to the point you can't handle, run the c:\windows\setup and change to vga to fix it.
7) The files currently in the win311 folder are modified setup text files, winfile (y2k update), and the TCPIP addon. These are free to distribute AFIK.
😎 No guarantees. No support. It works for me, if it doesn't work for you I don't really care.
9) Try with/adapt it to other versions if you want. Compare the infs. See the tricks that make it work.
10) I'll probably never run it again. It was just a puzzle to solve to automate it all to a fairly clean and working state.

Attachments

  • w311.JPG
    Filename
    w311.JPG
    File size
    147.44 KiB
    Views
    826 views
    File comment
    Fresh installed
    File license
    Public domain
  • Filename
    Auto-Dos-Win311-template.zip
    File size
    2.91 MiB
    Downloads
    69 downloads
    File comment
    Template iso
    File license
    Fair use/fair dealing exception

Things I built:
Mechwarrior 2 installer for Windows 10/11 Re: A comprehensive guide to install and play MechWarrior 2 on new versions on Windows.
Dos+Windows 3.11 auto-install iso template (for vmware)
Script to backup Win9x\ME drivers from a working install

Reply 1 of 9, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

😀 thanks

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox
DOSBox SVN snapshot for macOS (10.4-11.x ppc/intel 32/64bit) notarized for gatekeeper

Reply 2 of 9, by myne

User metadata
Rank Member
Rank
Member

No worries.
Just let me know it works 😀

Things I built:
Mechwarrior 2 installer for Windows 10/11 Re: A comprehensive guide to install and play MechWarrior 2 on new versions on Windows.
Dos+Windows 3.11 auto-install iso template (for vmware)
Script to backup Win9x\ME drivers from a working install

Reply 4 of 9, by flynnsbit

User metadata
Rank Newbie
Rank
Newbie

I mostly got through everything just fine.

Tested Dos 6.22 + Win3.11 for workgroups

I had a section of the install that unmounted the cd and just booted to dos with only smartdrv installed, remounted in VMware player and rebooted and it continued on its merry way. I think this was in between the dos and win install.

Because I chose to use SVGA and W311FW the login screen would cause the graphics corruption noted in the notes. I did at least figure out if you go change the IRQ for the AMD network card it will allow a graceful boot with SVGA + Network. That helped a lot and the only think that will bug out the screen is dos prompt.

Reply 5 of 9, by myne

User metadata
Rank Member
Rank
Member

What irq did you use?
It's set to.... 9? Or 11?in the network inf
Might need to test it with your setting

It's supposed to unmount the CD but it's supposed to continue... Hmm

Things I built:
Mechwarrior 2 installer for Windows 10/11 Re: A comprehensive guide to install and play MechWarrior 2 on new versions on Windows.
Dos+Windows 3.11 auto-install iso template (for vmware)
Script to backup Win9x\ME drivers from a working install

Reply 6 of 9, by flynnsbit

User metadata
Rank Newbie
Rank
Newbie
myne wrote on 2024-04-15, 21:38:
What irq did you use? It's set to.... 9? Or 11?in the network inf Might need to test it with your setting […]
Show full quote

What irq did you use?
It's set to.... 9? Or 11?in the network inf
Might need to test it with your setting

It's supposed to unmount the CD but it's supposed to continue... Hmm

This is what I ended up on and everything seems to be stable, dns etc works and no weirdness with login prompt. Everything seems pretty good if you stay away from the dos prompt.

Attachments

  • Capture.PNG
    Filename
    Capture.PNG
    File size
    14.35 KiB
    Views
    630 views
    File license
    Public domain

Reply 7 of 9, by myne

User metadata
Rank Member
Rank
Member

If you're comfortable editing infs, I'd be curious if it works better at to that to start with.

Just search for vmware in the network.inf

I won't be able to access a real computer for at least a few days

Things I built:
Mechwarrior 2 installer for Windows 10/11 Re: A comprehensive guide to install and play MechWarrior 2 on new versions on Windows.
Dos+Windows 3.11 auto-install iso template (for vmware)
Script to backup Win9x\ME drivers from a working install

Reply 8 of 9, by flynnsbit

User metadata
Rank Newbie
Rank
Newbie
myne wrote on 2024-04-15, 21:56:

If you're comfortable editing infs, I'd be curious if it works better at to that to start with.

Just search for vmware in the network.inf

I won't be able to access a real computer for at least a few days

Yeah sure, I'll give it a try later.

Reply 9 of 9, by myne

User metadata
Rank Member
Rank
Member

Cheers. I know I said no support, but I do want it to work.
I'm kinda hoping people will see the inf changes and add more hardware/patches etc. Or maybe even fix some of the gaps in the bats. I don't really like the invalid media type error, but it's all I could do that worked.
I left notes in the tricky parts of the infs.
The basic "slipstreamed" template with TCP, is, I think, a good foundation.

Things I built:
Mechwarrior 2 installer for Windows 10/11 Re: A comprehensive guide to install and play MechWarrior 2 on new versions on Windows.
Dos+Windows 3.11 auto-install iso template (for vmware)
Script to backup Win9x\ME drivers from a working install