VOGONS


First post, by jasa1063

User metadata
Rank Member
Rank
Member

I picked up an ATI VGA Wonder XL24. I have used the VINSTALL utility to try and set the monitor type, but the adapter refuses to set any modes above 640x480. When using VINSTALL to try and do diagnostics 640x480 is the highest resolution available. I have also tried to set custom resolutions and it just complains that is unable to set mode. I have tried both a KDS CRT monitor that I know works up to 1280x1024 and a Dell 19" LCD monitor that also works up to 1280x1024. The board reports it has 1MB of video memory installed. I have set the monitor type, saved to EEPROM and then power cycled the computer, but No luck. Any ideas on what might be wrong?

Reply 1 of 4, by weedeewee

User metadata
Rank Oldbie
Rank
Oldbie

can't recall when they switched from monitor ID pins to monitor Pnp(I2c) pins.
Maybe that is causing you problems?
Just a guess though.

Right to repair is fundamental. You own it, you're allowed to fix it.
How To Ask Questions The Smart Way
Do not ask Why !

Reply 3 of 4, by SA1988

User metadata
Rank Member
Rank
Member

Well, I need help setting up the ATI VGA Wonder XL24/VGA Charger (in 1mb mode) card under emulation for more than 640x480, too, I mean, what are the needed bits/regs of the 1024x768x256 mode for example? Or is it a video bios issue?

Reply 4 of 4, by jasa1063

User metadata
Rank Member
Rank
Member

I did some further testing on the computer that is having issues. On initial power on, it is not detecting the monitor properly. Doing CTRL+ALT+Delete and after that reboot the monitor is recognized properly and all video modes are available again. I am still doing more testing, but at least I have a work around in the computer I want to use it in.