First post, by RogrWilco

User metadata
Rank Newbie

Happy New Year folks! I'm putting together a 486—my first vintage build. I keep running into the same error trying to install 6.22 Plus Enhanced Tools from floppy. It boots from floppy, but then setup.exe fails to run with the "program too big to fit in memory" error. I've tried a number of different 6.22 and 6.2 images from a variety of sources and always have that problem. Interestingly, if I use a 6.22 Upgrade image, setup.exe launches fine, but I'm having other problems with that image.

I've checked the autoexec.bat on the install disk and all it has is nlsfunc, keys us, and setup.exe, in that order. My system reports 640K of base memory.

Any suggestions? Could it be a hardware configuration issue? Thanks a bunch.

Reply 1 of 2, by winuser_pl

User metadata
Rank Member

Check this out https://devblogs.microsoft.com/oldnewthing/20 … 130-00/?p=32483
The binary is corrupted most likely.

PC1: Highscreen => FIC PA-2005, 64 MB EDO RAM, Pentium MMX 200, S3 Virge + Voodoo 2 8 MB
PC2: AOpen => GA-586SG, 512 MB SDRAM, AMD K6-2 400 MHz, Geforce 2 MX 400

Reply 2 of 2, by Azarien

User metadata
Rank Oldbie

Usually it means that DOS doesn't recognize the file as an .exe file (the MZ header is missing) while it cannot possibly be a renamed .com file because it is bigger than 64k.

Corrupted file it is.

(this also means that DOS will happily attempt - and probably crash - to execute any corrupted .exe file that's smaller than 64k)