Jill of the Jungle Sound Effects

Getting old DOS games working on modern hardware. (DOSBox topics belong in DOSBox areas below, not here).

Jill of the Jungle Sound Effects

Postby Great Hierophant » 2012-2-26 @ 20:30

Since I built my 486 PC, I have been having problem's with JotJ's digital sound effects. The card I am using is a Sound Blaster 16 CT-1750 ASP w/DSP 4.05. Look here for the rest of the system specs :

viewtopic.php?t=31412

I had previously removed the Ultrasound, so it should not be an issue. I have also removed the Roland and the NIC without effect. I have tried booting with the bare minimum in AUTOEXEC.BAT and CONFIG.SYS.

In short, the problem is that whenever a digital sound effect plays, it sounds like growling. I can hear something of the true sound effect, but most of it is buried underneath the awful noise. The card in question has been tested and does not exhibit any problems in any other game I have yet tried. The music plays just fine.

The JotJ Trilogy version exhibits this problem, all three episodes. The standalone versions of Jill 2-3 I tried also exhibit the problem. The shareware versions of JotJ1, 1.0 and 1.2, do not exhibit this problem, but sometimes the sound effects randomly go silent for a period of time.
http://nerdlypleasures.blogspot.com/ - Nerdly Pleasures - My Retro Gaming, Computing & Tech Blog
User avatar
Great Hierophant
l33t
 
Posts: 2401
Joined: 2003-4-27 @ 08:20

Re: Jill of the Jungle Sound Effects

Postby DonutKing » 2012-2-27 @ 01:44

Very strange problem. I have a CT1740 with the same DSP version, 4.05, and I just tested Jill of the Jungle and can't replicate the fault you are having.

I don't have a CSP chip installed though, if that makes any difference.


This isn't really going to be much help but my opinion is you should ditch the SB16 for a card with better quality output- I used to use the CT1740 until I realised how bad the quality was, and the other SB16 models that have OK output have the hanging note bug. Now I use a YMF719 and run all my GM devices off that too.
If you are squeamish, don't prod the beach rubble.
User avatar
DonutKing
Oldbie
 
Posts: 1811
Joined: 2008-1-03 @ 03:23
Location: Australia

Re: Jill of the Jungle Sound Effects

Postby Great Hierophant » 2012-3-13 @ 16:02

I think I have finally licked most, if not all my sound problems, including this one. Here was my config.sys :

device=c:\dos\himem.sys
device=c:\dos\emm386.exe noems i=b000-b7ff i=e000-efff
dos=high,umb
files=40
devicehigh=c:\oakcdrom.sys [or vide-cdd.sys] /d:mscd001

Anything missing? How about a buffers command? If I add buffers=30, my sound problems go away. Sound effects that were missing, garbled or cutoff sound correct now. If the buffers command is not, present, then MS-DOS defaults to 15.
http://nerdlypleasures.blogspot.com/ - Nerdly Pleasures - My Retro Gaming, Computing & Tech Blog
User avatar
Great Hierophant
l33t
 
Posts: 2401
Joined: 2003-4-27 @ 08:20

Re: Jill of the Jungle Sound Effects

Postby keropi » 2012-3-13 @ 17:29

really? buffers? man, each day it's learning something new...!
User avatar
keropi
l33t++
 
Posts: 7297
Joined: 2003-9-08 @ 06:45
Location: Greece

Re: Jill of the Jungle Sound Effects

Postby Great Hierophant » 2012-3-14 @ 02:42

Apparently, that actually did not solve the Jill problem. I tried the game with a Sound Blaster 16 CT-2940 and the same problem occurred. It did not occur with a Sound Blaster Pro CT-1330A. Perhaps the system board's chipset does not do DMA 5-7 well.
http://nerdlypleasures.blogspot.com/ - Nerdly Pleasures - My Retro Gaming, Computing & Tech Blog
User avatar
Great Hierophant
l33t
 
Posts: 2401
Joined: 2003-4-27 @ 08:20

Re: Jill of the Jungle Sound Effects

Postby keropi » 2012-3-14 @ 07:49

so it's a plain old incompatibility problem... but it's so strange that a 486 has this...
User avatar
keropi
l33t++
 
Posts: 7297
Joined: 2003-9-08 @ 06:45
Location: Greece

Re: Jill of the Jungle Sound Effects

Postby Great Hierophant » 2012-7-07 @ 14:33

I had to replace my motherboard, which has the same SIS chipset as the old one, and the problem persists. On the CT2940, which is a PnP card, I tried a configuration that did not use a High DMA channel, but that did not help the problem. At least the SBPro works!
http://nerdlypleasures.blogspot.com/ - Nerdly Pleasures - My Retro Gaming, Computing & Tech Blog
User avatar
Great Hierophant
l33t
 
Posts: 2401
Joined: 2003-4-27 @ 08:20

Re: Jill of the Jungle Sound Effects

Postby h-a-l-9000 » 2012-7-07 @ 19:01

Tried playing with the ISA bus speed options?
1+1=10
h-a-l-9000
DOSBox Author
 
Posts: 4512
Joined: 2005-2-23 @ 00:14

Re: Jill of the Jungle Sound Effects

Postby Great Hierophant » 2012-7-08 @ 02:02

h-a-l-9000 wrote:Tried playing with the ISA bus speed options?


That may bear some fruit, as the new motherboard has more speed options than the previous one.
http://nerdlypleasures.blogspot.com/ - Nerdly Pleasures - My Retro Gaming, Computing & Tech Blog
User avatar
Great Hierophant
l33t
 
Posts: 2401
Joined: 2003-4-27 @ 08:20

Re: Jill of the Jungle Sound Effects

Postby Great Hierophant » 2012-7-08 @ 19:28

I tried it at three bus speeds within the 6-8.33Mhz AT/ISA BUS specification.

I tried version 1.0 of the first part, which is shareware and the Trilogy versions, which are 1.2d or 1.2e. In 1.0, the sounds are correct, but occasionally drop out and there is silence. In 1.2, I hear the "growly" effects.

My theory is that 1.0 uses code solely intended for an SB/SBPro, since when the game was released in 1992 the SB16 was just being released. 1.2 probably has explicit support for the SB16 and tries to use the High DMA channel. My chipset may have a faulty high DMA controller, even if only in a relatively subtle way. Since use of DMA5-7 was not very widespread, it may gone unremarked at the time for this particular SiS chipset. Also, the high DMA channels probably work fine for at least some other uses.

Can anyone confirm that Jill 1.2 is doing this?
http://nerdlypleasures.blogspot.com/ - Nerdly Pleasures - My Retro Gaming, Computing & Tech Blog
User avatar
Great Hierophant
l33t
 
Posts: 2401
Joined: 2003-4-27 @ 08:20

Re: Jill of the Jungle Sound Effects

Postby NewRisingSun » 2012-7-08 @ 19:34

DMA 5-7 are only used when playing 16 bit samples. Jill of the Jungle does not play 16 bit samples.

Actually, Jill2 and Jill3, from what I can tell, don't use DMA at all to play samples; they just use the peculiar method of sending PCM bytes directly to the DSP (using DSP command 0x10). The SB16 may sound worse with this method than the SBPro.
NewRisingSun
Oldbie
 
Posts: 852
Joined: 2005-9-02 @ 02:26

Re: Jill of the Jungle Sound Effects

Postby Great Hierophant » 2012-7-08 @ 23:48

It sounds downright terrible. Imagine Cereberus growling every time you landed from a jump or threw a dagger. If DMA is not to blame here, I find it difficult to believe that pure port writes would cause my motherboard to cause the issue.

Motherboard uses SiS 85C471 and 85C407 chips.
http://nerdlypleasures.blogspot.com/ - Nerdly Pleasures - My Retro Gaming, Computing & Tech Blog
User avatar
Great Hierophant
l33t
 
Posts: 2401
Joined: 2003-4-27 @ 08:20

Re: Jill of the Jungle Sound Effects

Postby NewRisingSun » 2012-7-09 @ 05:03

I find it difficult to believe that pure port writes would cause my motherboard to cause the issue.
The issue is the SB16, not the motherboard. Happens here too with an AWE64 and an ASUS motherboard.

I think the problem is that it's the SB16's dynamic low-pass filter (compared to the simple low-pass filter on the SBPro and no filter on simple SBs) which acts screwy with the DMA-less method of manually writing every PCM byte into the DSP.
Last edited by NewRisingSun on 2012-7-09 @ 18:22, edited 1 time in total.
NewRisingSun
Oldbie
 
Posts: 852
Joined: 2005-9-02 @ 02:26

Re: Jill of the Jungle Sound Effects

Postby DonutKing » 2012-7-09 @ 08:54

So does the shareware version play sound effects using a different method than the two registered episodes? because I was playing Jill1 'back in the day' on a 486 with SB16 and never had an issue.
If you are squeamish, don't prod the beach rubble.
User avatar
DonutKing
Oldbie
 
Posts: 1811
Joined: 2008-1-03 @ 03:23
Location: Australia

Re: Jill of the Jungle Sound Effects

Postby NewRisingSun » 2012-7-09 @ 18:14

Yes, shareware Jill1 just uses DMA. I notice that even under DosBox, Jill2&3's sound effects sound more grungy.
NewRisingSun
Oldbie
 
Posts: 852
Joined: 2005-9-02 @ 02:26

Re: Jill of the Jungle Sound Effects

Postby Great Hierophant » 2012-7-09 @ 20:32

Glad I kept the SB Pro then :)

The version of all three Jill of the Jungle episodes which came in my Jill Trilogy is 1.2(c). http://www.shikadi.net/moddingwiki/Jill_of_the_Jungle says that each episode has version 1.0, 1.2(a), 1.2(b), 1.2(c) and 1.2(d). 1.0 is the original shareware version.
http://nerdlypleasures.blogspot.com/ - Nerdly Pleasures - My Retro Gaming, Computing & Tech Blog
User avatar
Great Hierophant
l33t
 
Posts: 2401
Joined: 2003-4-27 @ 08:20

Re: Jill of the Jungle Sound Effects

Postby NewRisingSun » 2012-7-10 @ 06:51

I only have 1.0 and 1.2b. Before attempting to patch the games for DMA, I first want to find the latest versions (1.2d, according to the ModdingWiki list) to see what goes on there.

Edit: I have been sent version 1.2d of shareware Jill1, which also uses DMA. Registered version 1.2b used direct PCM instead. It would be worthwhile to track down version 1.2d of Jill2 and Jill3.
NewRisingSun
Oldbie
 
Posts: 852
Joined: 2005-9-02 @ 02:26

Re: Jill of the Jungle Sound Effects

Postby Great Hierophant » 2012-7-10 @ 18:34

I found version 1.2(d) and will try it in my pride and joy to see whether Epic managed to solve the problem.

Thanks for checking out this issue. As Jill Episode 1 was released as shareware, perhaps I should make it more available.
http://nerdlypleasures.blogspot.com/ - Nerdly Pleasures - My Retro Gaming, Computing & Tech Blog
User avatar
Great Hierophant
l33t
 
Posts: 2401
Joined: 2003-4-27 @ 08:20

Re: Jill of the Jungle Sound Effects

Postby gerwin » 2012-7-11 @ 17:45

Where can one find the version number of any of these Jill games?
User avatar
gerwin
l33t
 
Posts: 2725
Joined: 2004-5-07 @ 19:21
Location: NL

Re: Jill of the Jungle Sound Effects

Postby Great Hierophant » 2012-7-11 @ 19:13

gerwin wrote:Where can one find the version number of any of these Jill games?


I don't know, but you can tell the version by comparing the exe file size to the sizes given in the link to the modding site a few posts prior.
http://nerdlypleasures.blogspot.com/ - Nerdly Pleasures - My Retro Gaming, Computing & Tech Blog
User avatar
Great Hierophant
l33t
 
Posts: 2401
Joined: 2003-4-27 @ 08:20

Next

Return to DOS

Who is online

Users browsing this forum: No registered users and 4 guests