"Z" what a bugger to get going....

Topic actions

First post, by Phil K

User metadata
Rank Newbie

Hi. Got told about dosbox 6 by a gent off this board (thanks, Urban mate !) after hopefully asking on a newsgroup if anyone hadd managed to get "Z" working on XP. Bitmap brothers are not exactly helping (in fact they couldnt seem to care less about their old games not working on newer systems) but I loved the game, and was desperate to play it again as it is light years better than their later Z2 steel soldiers. Anyway - I gave dosbox a try, and - no. I get "critical file missing, main.pac" Whatever the hell that is. So bloody close.....

Cant understand it. The Z disk has not been touched for the 18 month - 2 years or so I've been on XP, and it couldn't have deteriorated surely ? 😕

ANY help whatsoever will be greatly accepted.

Oh yeah :-
P4 2.0ghz
2x80gig HD's
512 ram
MSI/Medion motherboard

Phil Kennedy

Reply 1 of 21, by eL_PuSHeR

User metadata
Rank l33t++

You could try checking the cd-rom for read errors. Try copying all files to a folder to see if there are any read errors. If there aren't any, then try other alternatives.

Under VDMSound (another app. mentioned on these same forums), you could also try using SAPUCDEX (a mscdex replacement) and quite good as it seems. You will have to download it first, of course. It's a separate application.

Good luck and please keep us posted.

BTW: The emulator DOSBox if for MS-DOS games/apps only.

Last edited by eL_PuSHeR on 2003-10-23, 10:52. Edited 1 time in total.

Reply 2 of 21, by Snover

User metadata
Rank l33t++

There have been previous threads on "Z", but of course you can't find them because Bitmap Brothers were all like, "hey, let's be cool and make our game name one letter long!" I don't quite recall if/how it was ever able to run; one of the other moderators should be able to remember more, though.

Just so you know, pressed CDs do not deteriorate like CD-Rs and CD-RWs do, so you needn't worry about that. Rather, worry about scratching the disc's surface (on either side; scratching the read side will prevent the data from being read properly, scratching off the reflective label will effectively permenantly remove the data, rendering the disc completely useless).

And also, it's DOSBox 0.6. Unlike the commercial industries, we actually know how to label software build numbers. 😜

Yes, it’s my fault.

Reply 3 of 21, by Devilsadvocate

User metadata
Rank Newbie

i got z working after following procedure.

- install z (uh yeah who would have guessed 😉
i installed mine to d:\program files\z

- copy the whole cd content to a folder of your choice, i copied it into following one:
d:\program files\z\cd

- open up dosbox.conf with a text editor, it's in your dosbox folder.
mine looks as follows:

# fullscreen -- Start dosbox directly in fullscreen.
# autolock -- Mouse will automatically lock, if you click on the screen.
# sensitiviy -- Mouse sensitivity.
# waitonerror -- Wait before closing the console if dosbox has an error.


# language -- Select another language file.
# memsize -- Amount of memory dosbox has in megabytes.


# frameskip -- How many frames dosbox skips before drawing one.
# snapdir -- Directory where screenshots get saved.
# scaler -- Scaler used to enlarge/enhance low resolution modes.
# Supported are none,normal2x,advmame2x


# cycles -- Amount of instructions dosbox tries to emulate each millsecond.
# Setting this higher than your machine can handle is bad!


# nosound -- Enable silent mode, sound is still emulated though.
# rate -- Mixer sample rate, setting any devices higher than this will
# probably lower their sound quality.
# blocksize -- Mixer block size, larger blocks might help sound stuttering
# but sound will also be more lagged.
# wavedir -- Directory where saved sound output goes when you use the
# sound record key-combination, check README file.


# mpu401 -- Enable MPU-401 Emulation.
# device -- Device that will receive the MIDI data from MPU-401.
# This can be default,alsa,oss,win32,coreaudio,none.
# config -- Special configuration options for the device.


# sblaster -- Enable the soundblaster emulation.
# base,irq,dma -- The IO/IRQ/DMA address of the soundblaster.
# sbrate -- Sample rate of soundblaster emulation.
# adlib -- Enable the adlib emulation.
# adlibrate -- Sample rate of adlib emulation.
# cms -- Enable the Creative Music System/Gameblaster emulation.
# Enabling both the adlib and cms might give conflicts!
# cmsrate -- Sample rate of cms emulation.


# pcspeaker -- Enable PC-Speaker emulation.
# pcrate -- Sample rate of the PC-Speaker sound generation.
# tandy -- Enable Tandy 3-Voice emulation.
# tandyrate -- Sample rate of the Tandy 3-Voice generation.
# disney -- Enable Disney Sound Source emulation.


# Nothing to setup yet!

# xms -- Enable XMS support.
# ems -- Enable EMS support.
# dpmi -- Enable builtin DPMI host support.
# This might help in getting some games to work, but might crash others.
# So be sure to try both settings.


# modem -- Enable virtual modem emulation.
# comport -- COM Port modem is connected to.
# listenport -- TCP Port the momdem listens on for incoming connections.


# Lines in this section will be run at startup.

mount C D:\Progra~1\z
mount D D:\Progra~1\MONKEY1
mount E D:\Progra~1\MONKEY2
mount F D:\Progra~1\DUKE3D

mount G D:\Progra~1\Z\CD -t cdrom

- now adapt it to your settings, change the paths of the game, etc. Also check what cycles are good for you (you may change them with ctrl -F11 and ctrl-F12). I got a 2ghz cpu, too, and these settings work very well for me, although I still have to change the cycles every time I start the game.

We these settings enabled you can just start the dosbox, type in Z and the game will start. It's that easy... 😉

Reply 4 of 21, by Stiletto

User metadata
Rank l33t++

Went digging.

These should be the important threads:
another "Z" thread

My verdict: Use DOSBox. 😉

"I see a little silhouette-o of a man, Scaramouche, Scaramouche, will you
do the Fandango!" - Queen


Reply 6 of 21, by un[skill3d

User metadata
Rank Newbie

ok, probelm solved:
open the z.bat with the texteditor, there should be:

@Echo Please Wait - Loading ......
@ZED.EXE /CD:X %1 %2 %3 %4 %5

put your cdrom drive in dosbox instead of the X

PS: thanks a lot Devilsadvocate[/b]

Reply 10 of 21, by jamieb

User metadata
Rank Newbie

Athlon xp 3200, Win XP, 1 gig ram, radeon 9800 pro 128mb

I got z working using the tips on this page. I was finding the game quite tough in the later levels so I looked up some cheats on gamespot and various other sites. But when I tried them they didn't work. They use the ctrl and alt keys. Could it be that dosbox has reserved these keys for windows?
The cheats are:
ctrl+tetsuo - god mode
ctrl+ack - full health
alt+psion -all weapons
Can anyone help?

Reply 12 of 21, by HTMC

User metadata
Rank Newbie

Hello. I'm using a HP Home media Pc with XP and 504 RAM, using the newest edition of DOSBox (.62...?)

I've tried both what devilsadvocate and un]kill3d have said, and am still not getting Z to work. i'm getting the error: main.pac is missing. It also, on the other screen, says that options.cfg is set to read-only, but i've checked and it is not.

I would really appreciate help with this, since I want to play this game rather badly.



Reply 13 of 21, by HTMC

User metadata
Rank Newbie

Just to be more specific...

I installed Z without DOSBox, and have all the files on my c drive

So, open DOS BOX

mount c c:\z\



I then get a loading sign, followed by "Critical File Missing: main.pac"

and on the status window: A number of serial port messages, followed by Warning: file c:\z\OPTION.CFG exists and failed to open in write mode
Please remove write-protection.

Again, it is set to read and write.

Please help.


Reply 15 of 21, by HTMC

User metadata
Rank Newbie

z:\>mount c c:\
Mounting c:\ is NOT recommended. Please mount a (sub)directory next time
Drive C is mounted as local directory c:\


C:\>cd z


[loading screen]

Critical File Missing: main.pac

As you can see, it still refuses to work 🙁

Reply 17 of 21, by KISSMAD

User metadata
Rank Newbie

Try this
Open the "z.bat" file from the game folder into notepad. It should look like this.

@Echo Please Wait - Loading ...... 
@ZED.EXE /CD:X %1 %2 %3 %4 %5

Open the "dosbox.conf" file with notepad from where you installed Dosbox. At the bottom of the file, It should look like this.

# Lines in this section will be run at startup.

mount C C:\Games\z

mount X C:\Games\Z\CD -t cdrom

Change the letter X in both the "z.bat" and "dosbox.config" to the letter of your CD/DVD drive. IMPORTANT. Both of the X's must be the same otherwise you will still get the "main.pac" file is missing error message. If you have more than 1 CD/DVD drive, try them all. Overwrite both files if you have changed anything.

The only Z website you need - ZZone

Reply 18 of 21, by boxrun

User metadata
Rank Newbie

For those have trouble with the rip of Z and z: already being mounted by dosbox

Try changing your Z.bat file

@Echo Please Wait - Loading ......
@ZED.EXE /CD:C:\Z %1 %2 %3 %4 %5

Presuming that you have mounted c: outside the z folder
ie mount c c:\games where Z is in c:\games\z

Reply 19 of 21, by PrimalShadow

User metadata
Rank Newbie

Sorry to resurrect quite an old thread, but I seriously want to get this classic working again.
I never got to finish Z (got stuck on one of last levels as a kid), and now I get this 'critical file missing: main.pac' error. Tried the solutions in here, did not work. My CD seems only lightly scratched. Last time, years ago (obviously), it worked fine.
Wonder if someone has encountered a solution by now, and if not, if the person that wanted to buy a new CD to play it actually found one. And of course if that CD did work for him with DOSBox.

Thanks in advance,