VOGONS


First post, by MrFlibble

User metadata
Rank Oldbie
Rank
Oldbie

Flying Tigers is a shareware DOS vertical-scrolling shooter game. Several versions of it exist, of which the latest is v2.10, released in April 1995 (tiger21.zip). While versions below v2.10 run normally in DOSBox, v2.10 locks up right after the title screen, with the DOSBox console showing these errors:
bpKt6kf.png

I have tried various combinations of machine and CPU core and type settings, cycle values, sound cards (as well as running the game without sound) etc. both in several builds of vanilla DOSBox and third-party SVN builds (mostly SVN Daum), and also tried replacing the DOS4GW extender with DOS32A and turning off EMS emulation. However none of this helped solve the issue.

The game generates a file called PROBLEMS.TXT, with the following contents:

!!! starting program
--- checking files for crc check
--- writing cover page
-- malloc 1
-- malloc 3
-- malloc 4
-- malloc 5
-- malloc 6
--- loading blimps/shadows
--- loading graphics
loading 1
loading 3
loading 4
loading 5
loading 6
loading 7
loading 8
loading 9
loading 10
loading 11
loading 12
loading 13
-- init list 1
-- init list 2
-- init list 3
-- init list 4
-- init list 5
-- init list 6
-- init keyboard 1
-- init keyboard 2
-- init sound system
-- init register drivers
-- dinit
-- load sfx
-- voice setup
-- read previous settings
-- create calc table
-- set mode
-- calc paging system
-- start polling
-- set mode
-- load pcx file
-- begin animation loop
-- start song
-- fade in music

There are several older versions of the game, none of which have this issue. Version 2.10 runs in FreeDOS, so it's not a problem on the part of the programme.

DOS Games Archive | Free open source games | RGB Classic Games

Reply 1 of 2, by ripsaw8080

User metadata
Rank DOSBox Author
Rank
DOSBox Author

The game tries to change the current directory to ... (three dots) and messes up if a "path not found" error is not returned, which seems like buggy behavior to me. DOSBox is handling it like a change to the grandparent directory -- I recall that Novell workstation shells would interpret it that way on network drives, so perhaps the game is performing an obtuse network check, but compatibility with plain DOS is probably preferred.

The issue can be avoided by mounting the game directory as the root directory because it causes the grandparent change to fail, but mounting like that is usually not recommended. For normal situations where the game is in a subdirectory, and until the issue is fixed in SVN, here is a workaround program that will return the necessary error response. Place the program in the game directory and run it to start the game.

Attachments

  • Filename
    FTFIX.ZIP
    File size
    236 Bytes
    Downloads
    47 downloads
    File license
    Fair use/fair dealing exception