Topic actions

  • This topic is locked. You cannot reply or edit posts.

First post, by Stiletto

User metadata
Rank l33t++

I thought I'd start a POD thread for those readers who want to experiment with POD, Glide, a glide wrapper, and Win2000/XP.

Here's some awesome sites for POD patching instructions, etc. Recommended reading (but beware of broken links!)

POD Underground: http://www.kineticdreams.net/underground/
PODTek: http://www.infectedfiles.com/podtek
QBall's Knarly POD Site: http://www.spiritfreedom.net/pod
Witness Team: http://witnessteam.free.fr
PODCafe: http://www.podcafe.com

I'll post more info when I get a chance. Best thing going for this game? The reverse-engineers, track and car creators, patchers, skinners, etc. - that whole scene is/was quite healthy. Like Red Baron 3D, having an active community is a good thing. 😀

"I see a little silhouette-o of a man, Scaramouche, Scaramouche, will you
do the Fandango!" - Queen


Reply 1 of 49, by CraigG

User metadata
Rank Member

The trouble is, a lot of the POD community have disbanded, their websites taken down, and all links broken.

I've been trying to get pod working for weeks, but it just refuses to even run, and on any OS.

It could be an AMD thing, but it's more than likely a directX thing.
Even the software version refuses to work, but at least it runs, it's just the graphics are totally messed up.

If I could get a fully working POD, then I'll work on getting the glide version working.
The installer works fine, it even detects a glide card.

Perhaps now is a good idea to get all the ideas in one basket, and that basket is here in this thread.

Athlon 64 3000+ stock
MSI NForce 4 K8N Neo Platinum
nVidia Geforce 6800GT stock clocks
SBLive! Platinum + Audigy ZS2 Drivers
WinXP Pro SP2

Reply 3 of 49, by Craig

User metadata

I'm still around, now and then.

It's nothing to do with those suggestions, the game just doesn't run full stop !!

Those suggestions are for people who are able to run the game, but get graphic corruption.

I'd just like to be able to run the game, but it just does nothing.
It's as if it checks the CD, but can't find the files.
I've cracked it, used a CD emulator like Daemon Tools, but still get nothing.

I'm still sure it's an AMD thing, as I can remember having those exact problems back in my K6-2 days.


Reply 4 of 49, by procerus

User metadata
Rank Newbie


Have you tried the Force Feedback patch? It says here-
that it fixes problems with AMD CPUs.

98lite with 629K of free conventional memory in full DOS mode using QEMM 9.0 (or 628K with UMBPCI.SYS providing real mode for FastVid) with SmartDrive, CD-ROM, CuteMouse, sound support and UniRefresh all loaded high.

Reply 6 of 49, by Unregistered

User metadata

the biggest problem with pod is that you have to have certain hardware or some parts just don´t get recognized/installed.
The Game Service patch (which also came with POD gold or the upgrade disc which was sold separately) is still available from UbiSoft Europe afaik, but if you don´t install the 3dfx version right from the start you´ll miss the high-res cars and tracks.
Here´s a small help on how to install ANY version of pod you want on ANY system:
copy the whole content of your install disc to a folder on your HD
look for a folder called instdata and the file ubi.ins contained in it, edit this file in a text editor as you wish (I strongly suggest to get rid of the Intel Indeo and Directx installation, it comes with any modern OS but the version on the ubi disc won´t install on newer OSes and if any part of the install fails the installer erases the game from your hd!)
Burn the contents of this folder back on a fresh cdr and off you go

The game service patch for 3dfx allows you to use glide 2.x instead of glide1 which is what the original game uses. Therefore the game is playable with wrappers after patching, I got it to work in a window with mglide in full 3dfx-glory. Remember to start it in win98-compatibility mode if you´re running winxp

Reply 8 of 49, by Craig

User metadata

You don't need to copy the game to HD, edit, burn etc..

When you install, you just click on "Software Tests", and untick DirectX and Indeo, and it won't install them.

But I still can't run the damn game.

With a full install of the 3dfx version, it just does nothing.
Double click on Wpod3dfx.exe, and nothing happens.

So I can't even tell whats wrong.
Even with Regmon running, you still can't see where it's looking or failing.


Reply 9 of 49, by Unregistered

User metadata

my original POD2.0-version (not gold) does not have the ability to skip those tests!
And you need to update to 2.5 (or was it 2.1?) via the game service patch (there is a separate patch for 3DFX, about 23megs if I´m not mistaken), because otherwise it will try to use glide1 instead of glide2 (i.e. it would need glide.dll, sst1init.dll, fxmemmap.vxd - the installer normally searches for these 3 files, dunno if the game itself does, too. Before patching the install routine I just created 3 dummy files and installed that way).
The bonus disc I bought was called Pod - back to hell and it has almost every official downloadable car and track on it plus all patches (voodoo, voodoo rush, powerVR, S3-Virge, Ati3D, D3D, software).

and by the way: pod uses windows glide anyway, no need for glidos here.

edit the 3rd: okay, found your "software tests" option, it is there, I admit I´m dumb 😉
But that doesn´t solve the 3dfx problem, I´m working on a foolproof installation concept (my second installation of pod isn´t working too and my first just stopped, dang!)

Last edited by Unregistered on 2002-11-03, 23:08. Edited 1 time in total.

Reply 10 of 49, by Craig

User metadata

POD Gold, is V2.8, so it's even newer than the patch.

So I guess it contains ALL the patches in one new release.

I don't believe my problem is Glide related.
The installer checks for glide before it installs, and it says it's ok.

When you run WPOD3dfx.exe, Openglide must get initialised as the ini and log file appears.

It could be a DirectX version thing ? I'm using DX8.2

It could be a CD authentication check ? I'm using an image with Daemon Tools. But the original does the same <shrugs>

Reply 13 of 49, by Unregistered

User metadata
Unregistered wrote:

The bonus disc I bought was called Pod - back to hell and it has almost every official downloadable car and track on it plus all patches (voodoo, voodoo rush, powerVR, S3-Virge, Ati3D, D3D, software).

Hey, that's pretty rare! German-only release, I think. It's possible it might be the German-only name of an American release too, but I don't know what it would be.


Or in English:

They want to release an add-on for POD-owners: POD - BACK TO HELL: […]
Show full quote

They want to release an add-on for POD-owners:

It will include 16 tracks, 3 of them are new ones(and will not be released on the net!!!), the rest is allready on the net:

Hellway (description points to the graveyard track!? Friedhof = Graveyard)
Beach (180 Turns in a recreational area)
Alderon (are you afraid of the dark?)
They promise BOTS!!!

8 Motorbikes!!!!

+ some well known cars:

+ the POD Desktop Utilities
+ the final version of PODnet
+ MMX-Upgrade to Version 2.0
+ all available patches
+ support for all D3D-compatible cards


Reply 14 of 49, by Stiletto

User metadata
Rank l33t++

Sorry, that was me.

A little more on Back To Hell:

16 official tracks + Nigh + Beach and Hell are on the disk. That means that "only" Iceberg is missing (Fallen, Aztec and all the commercial versions of Special of course are missing, too). {I am not surprised, as they are "unofficial" -Q}. All the Patches are on the disk, too (and this desktop stuff). Instalation works by the CD Patcher 2 (runs/installs directly from CD). All the bikes and boats are there, too - but only 8 "old" add on cars - and only the Arakn is a "fast" one. The Price is 25DM - what is around 12 US Dollar (I think). If they would have included Iceberg and the good cars (Shark, Stinger, Stealth, Fuego, Catamax) instaead of all the bad one I would have called the disk PERFECT. But anyway the hard disk space I can save now (backed up all stuff this time, afeter the installation of the patch) is worth the 25DM alone! I think it was finally released on monday here (Germany) but some shops seem to have started to sell it on Friday and Saturday.

Reply 16 of 49, by Stiletto

User metadata
Rank l33t++
Unregistered wrote:

But that doesn´t solve the 3dfx problem, I´m working on a foolproof installation concept (my second installation of pod isn´t working too and my first just stopped, dang!)

I guess the thing to do would be to purchase all the versions of POD you could and create a new installer that would work with pretty much any version. And then a cool patch-installer thing would be nice as well.

BTW, you really should register, Unregistered... 😀

"I see a little silhouette-o of a man, Scaramouche, Scaramouche, will you
do the Fandango!" - Queen


Reply 17 of 49, by LSD

User metadata
Rank Member

I have an idea: Bar 'Unregistered' as a valid user name (while still allowing Anonymous posting). That way, they'd be forced to put something in there :p

...watashi ga iru koto o.
Itsudatte soba ni iru yo.

Gentoo. Because everything else is just shit. 😁
Registered Linux user #319839

Reply 18 of 49, by Unregistered

User metadata

well, this machine has an automatic cache and cookie cleaner and my list of passwords for forums is already more than a A4-sheet so... bear with me for a little longer like this, k?
I´m just setting up a win98 machine, will take me the whole evening I guess but I´ll try to install POD on it and document on where it fails to run. If it won´t run p.ex. after the DX8-install we have the culprit!

Reply 19 of 49, by Stiletto

User metadata
Rank l33t++

Hey, cool, fun!

So I gave OpenGlide a try with POD for the first time last night, on my home computer! (See profile)
POD Executable: wpod3dfx.exe
POD Version:
(POD OEM 1.0, retail cars installed from Q-Ball's, patched to 2.0, then patched to latest version)

Here's what usually happens:
The program displays the 3dfx logo (using 3dfx's drivers), then switches to 640x480x16 bit and displays the UbiSoft logo, then switches resolutions AGAIN to play the opening movie. After that, it switches resolutions at least one more time and goes to the in-game menu.

Here's what happened with OpenGlide:
The program did not display the 3dfx logo (so I know part of OpenGlide was working), then switched to 640x480x16 bit full-screen and displayed the UbiSoft logo, then went to play the opening movie - and crashed! I was back to the desktop in 640x480x16 bit (I usually run at 1024x768x32 bit). Wish I could have been back at my usual resolution after the crash - I had to change it manually. So I set "InitFullScreen=0" in OPENGLID.INI and didn't have to worry about it anymore. It displayed the logo okay in the window, so I know OpenGlide was working at that point.

Anyhow, to get back to the crash - from Faultlog.txt:
"Date 11/04/2002 Time 19:41
WPOD3DFX caused an invalid page fault in module 3DFXOGL.DLL at 025f:6901c2d4.
EAX=00774f0c CS=025f EIP=6901c2d4 EFLGS=00210292
EBX=00000000 SS=0267 ESP=08a0fefc EBP=08a0ffcc
ECX=00000000 DS=0267 ESI=00774f0c FS=4fff
EDX=00774f0c ES=0267 EDI=007a9de8 GS=74ae
Bytes at CS:EIP:
ff 91 fc 01 00 00 8b 47 64 80 78 55 00 74 42 8b
Stack dump:
00870f00 007aa1a0 00000000 6900ba68
00000000 00000f3e 7ac01032 00000f3e
00000000 7abd406c 00000f3e 08a0ffcc
817fab40 004ecf1a 00000000 bff27936"

That's okay, though. Keep in mind that my Win98 installation is EXTREMELY WONKY and things have been crashing, off-and-on, at location 025f:something for over TWO years and I don't know why. (That's what you get when you have so much crap installed that you can't really even do a reload). Quake3 (without OpenGlide) runs okay, though. *shrug*

Note that wpod3dfx.exe usually crashes, anyhow, when I exit the game - it locks up and I have to axe the executable in Ctrl-Alt-Del "Close Program". It leaves me with graphics glitches that I have to change the resolution, then change back, to get rid of.

I also tried POD 3dfx as well:
POD Executable: podx3dfx.exe
POD Version:
Same crash, same error message at same location.

I also tried disabling the intro movie in the in-game options, it did not solve the crash problem.

Another thing - the cursor appears in front of the game window using OpenGlide, and it should not. I saw my hourglass pointer spinning in front of the video window. It usually should not appear.

So I think there's a good chance POD could run, if I had a working PC! I'll give it a shot some other time at school.

My OPENGLID.ERR file consisted of one entry: "grBufferClear: OpenGLError = invalid operation"

Attached is my OPENGLID.LOG.

Final comments: Without OpenGlide, the Direct3D and Glide versions of POD work fine. The DirectDraw version, however, has this particular issue under Win98:

Additional Notes:
Using the final official version of 3dfx drivers.

3dfx Info
Voodoo3 PCI
Current Display Adapter Information
Manufacturer : 3dfx Interactive, Inc.
Hardware Version : 001
Bus Type : PCI
Total Video Memory : 16 MB
Graphic Chips : 1
Graphics Clock Speed : 166 MHz
BIOS Version : 2.15.07
Current Display Driver Information
Product Supported : Voodoo3 PCI
Version :
Provider Name : 3dfx Interactive, Inc.
Release Date : 11-10-2000
3dfx Tools Version :
3D Filter Quality : High
Alpha-Blending : Smoother
Level of Detail Bias : -2
Z-buffer Optimization : Enable
3D Filter Quality : High
Alpha-Blending : Smoother
Glide Splash Screen : Disable
Depth Precision (16 Bit) : Faster
Level of Detail Bias : -2
Limit Texture Memory : Software Controlled
Maximum Buffered Frames : 3 Pending Buffers
MIP Map Dithering : Disable
Triple Buffering : Enable
Vertical Sync : Disable


  • Filename
    File size
    491 Bytes
    File license
    Fair use/fair dealing exception

"I see a little silhouette-o of a man, Scaramouche, Scaramouche, will you
do the Fandango!" - Queen