First post, by daspectrum

User metadata
Rank Newbie


im fairly new to the dos emulation work. I have run into an issue that if someone could five me some advice would be great. the issue i am having is that i configure the sound in the STTNG.ini and dosboxconf.ini file the same for the sound card SB16 port 220 irq 0x7 dma 0x5 hdma 0x5 which allows the sound to come out perfectly. This however stops the mouse, you cant move it you cant capture it nothing it is just as dead as a doorstop. you change the dma setting to 0x1 settings you get no sound and your mouse is moving (this is the only combination i have had to get the mouse moving) does anyone have some advice i have tried numerous combinations there has to be a conflict here but i cant pin point it.

Reply 1 of 6, by Rwolf

User metadata
Rank Newbie

Are you using identical dma channels? Normally DOS used low dma 1-3 and high dma 5-7 for the SB-16 depending on what other hardware was in your computer.
(I have the game somewhere in storage, but I have not tried it in DOSbox, so I hope this is the problem. If not I can dig it out to try.)

Reply 2 of 6, by ash403638

User metadata
Rank Newbie


I'm not sure if I should make a new thread as this one is very recent and I'm having a similar issue with my mouse. The sound works fine but the mouse won't move at all, it's firmly stuck on the screen. I've tried using ctrl+f10 with no luck and I've tried adjusting the config file to disable autolock. I've searched on google for the past hour and have had no luck so far.

My sound settings are these:


Everything else is working fine.

Reply 3 of 6, by Rwolf

User metadata
Rank Newbie

I just tried this game in DosBox, and for me it works fine, no mouse/sound problems (other than some minor skips when loading new dialogue, then background sounds stops temporarily, could probably be fixed by increasing cpu cycles.)

My sound settings are the same as 'ash403638'; using dosbox 0.74 with 'D-Fend Reloaded 1.44' front end.
I did let the game autodetect sound settings during installation, and it found my preset SB-16 settings, with all other emulated sound devices turned off. The game itself is v1.0

Using the mouse & subtitles on, I used the mouse for dialogue selection in the initial mission and the menu navigation, all working fine here. Running DosBox under XP64, which may not be what you have.

Reply 4 of 6, by red_avatar

User metadata
Rank Oldbie

Final Unity has worked fine for many years but the only issue I always had, was with mouse movement being slow or inaccurate, even with mouse speed set to maximum. Someone gave me a patch for that years ago on this forum. It may be related to your issue.

Other than that, I have the same settings you have.

One thing I do that many people don't: LIMIT YOUR CYCLES. I think that most front ends set it to max or auto and that causes a LOT of problems for certain games. Games like Lemmings won't have sound and some outright crash or have other issues if you give them too many cycles. For Final Unity, 70.000 cycles should be plenty.

Retro game fanatic.
IBM PS1 386SX25 - 4MB
IBM Aptiva 486SX33 - 8MB - 2GB CF - SB16
IBM PC350 P233MMX - 64MB - 32GB SSD - AWE64 - Voodoo2
PIII600 - 320MB - 480GB SSD - SB Live! - GF4 Ti 4200
i5-2500k - 3GB - SB Audigy 2 - HD 4870

Reply 5 of 6, by Deamas

User metadata
Rank Newbie

If your mouse isn't working try changing the output to ddraw


I post this because it was one of the first results when I googled this question and figured I'd share in an easily findable place.

Reply 6 of 6, by Jo22

User metadata
Rank l33t++
Deamas wrote on 2021-09-08, 01:35:

I post this because it was one of the first results when I googled this question and figured I'd share in an easily findable place.

Another A Final Unity here! ❤️

Thanks a lot! ^^

I played the game a lot on a Pentium 75 Compaq PC at the turn of the millennium!
Later on, I played it in DOSBox v0.63, I think, on an Athlon 64 x2 running Windows XP SP2 (I think).

About 60k/70k seems right, also.
Also used DDraw back then due to its pretty bilinear filtering.

Edit: Direct Draw is emulated through Direct3D since Vista..
So it may look ugly on such systems.
The DXGL wrapper maybe can help here.
Or let's just put the ddraw.dll from XP into the DOSBox folder. It may force Win Vista+ to a proper DDraw software-rendering through good ol' GDI.

PS: The game even ran playably on a 80386 mainboard with a Cyrix/TI 486DLC-40 and an extra 387 FPU!
The only thing thst did not work, were the 3D combat scenes.
They were absolute slide-shows!
I used a serial mouse, by the way. 😉

"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//