First post, by gladders

User metadata
Rank Member

Hi all,

I'm aware this is the third thread I've posted about this machine this week but each time there's some new issue and this one is a whopper.

So it's a Pentium 90 from 1995. I took out the two internal batteries that tend to leak and corrupt the innards, so they're not to blame.

The original hard drive was badly damaged although it still booted, so I replaced it with a 2GB CF card adapter, which has worked quite well so far. I installed DOS 6.22 and Windows 3.11.

Anyway in the process of installing drivers, the IntelliPoint mouse would not work for some reason, although putting a mouse in the PS/2 port worked fine. But I wanted the IP to work.

I think the weirdness began with an attempt to load into the BIOS at boot last night, in order to try to adjust how the machine handles an external mouse being plugged in. Well it loaded the BIOS once, and then on rebooting, the computer would not boot.

Or so I thought. I plugged the computer into an external monitor and it was booting, just the screen wasn't working.

Fine, I think, I wasn't going to take this machine anywhere, so if I can only operate it with a monitor, so be it.

After a bit of tinkering around, I did a restart, to go into BIOS again, and this time, it hung at the RAM check. Reboot, and this time it wouldn't even get that far - only to a blinking '-' in the top left.

Aw, shit.

But this morning I thought I'd try one last thing. I put the old broken hdd in, and it booted as normal - laptop screen and everything, although it refuses to acknowledge any PS/2 mouse or IntelliPoint.

Swap the CF card back in, and that boots up just fine.

But then the moment I try to access the BIOS, the whole thing screws up again. I have to swap hard drives - and the old broken hdd working isn't a guarantee, I've noticed - before it'll start behaving again.

I *think* something to do with the PS/2 port is causing the BIOS to freak out, maybe? Because it definitely worked before. I did change the sound card IRQ from 10 to 7 to ensure Windows 3 would produce sound, but no idea if that affected PS/2 operation at all.

Any help?

Reply 2 of 2, by gladders

User metadata
Rank Member

Well, thanks for reading anyway. I think I’ve figured it out. The main battery is unsurprisingly absolutely dead, and that was causing a malfunction. I have a second battery which can hold about ten seconds of charge and that fixes the problem.