VOGONS


Reply 380 of 440, by FreddyV

User metadata
Rank Member
Rank
Member
zyga64 wrote on 2020-04-09, 08:59:

When first module I'm trying to load is Time... by Fugaz / ByteLand (16 channel s3m module) this module plays correctly and every other s3m after it also plays correctly.
But when I'm trying to load at first another s3m, for example Bad Weather by Well / Obfuscation I cannot play it until I load one of "good" s3m's. No matter which mixing frequency I set for this particular module. I didn't noticed this on b16. So far every 4 channel mod I've tested sounds good, everytime.

Hi,

I will test this.
I have an S3M module that did this as well, it is still in the known bug list.
But I "Forgot" To debug it.

Some internal variables are not set correctly sometimes 🙁

Edit: I tried under DOSBox and I can play Times after Bad Weather. What do you mean by you can't play it anymore ?

Last edited by FreddyV on 2020-04-09, 17:58. Edited 1 time in total.

Reply 381 of 440, by FreddyV

User metadata
Rank Member
Rank
Member
root42 wrote on 2020-04-08, 19:19:

I tried Matze79's LPT DAC the other day -- and it works. But only at ~10KHz. More and you get choppy sound. Is this expected? I guess so, since the 386 is bit banging the LPT port.

Testing Beta 17 right now with the Snark Barker. Video later...

I saw your video.

I suppose that even an XT computer can do 10KHz 4 channels on LPT.
Did you test other MOD Player ?

If you do F6 you can check if it is too slow with the Count3 displayed.
Also, are you mixing in 16bit ?
You used the Beta16 version, not 17.

I definitely need to test more then.
Edit:
Tested on a Pentium 75 , No problem

Reply 382 of 440, by matze79

User metadata
Rank Oldbie
Rank
Oldbie

i can bang out at least 22Khz on 386 33Mhz SX.
But i use glx player..

maybe there is some bug?

note that it is only using 10% resistors as i got a Huge Pack of them.. 😀

EDIT:
on V20 9,54Mhz i get around 11Khz~ with MODM 112XT

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer

Reply 383 of 440, by root42

User metadata
Rank Oldbie
Rank
Oldbie

Here is my test video:

https://youtu.be/ruvx0Fwklxs

DATAJACK.S3M crashes the player.

YouTube and Bonus
80386DX@25 MHz, 8 MiB RAM, Tseng ET4000 1 MiB, SnarkBarker & BlasterBoard, PC MIDI Card + SC55 + MT32, XT CF Lite, OSSC

Reply 384 of 440, by zyga64

User metadata
Rank Member
Rank
Member
FreddyV wrote on 2020-04-09, 17:16:

Edit: I tried under DOSBox and I can play Times after Bad Weather. What do you mean by you can't play it anymore ?

It looks like this:
- I'm trying to load Bad Weather as a first module - I'cant.
- When I'm loading Times it plays normally
- I'm trying to load Bad Weather again - it plays normally

If you start program with "good" module - you can play everything.
If you start with "bad" module, you can't play "bad modules", until you load "good" one.

Youtube example: https://youtu.be/QjorLLSa_kc

Beta 16 don't have this indisposition. I've tested it a minute ago.

1) SCAMP /286@20 /4MB /TVGA9000C /CMI8330
2) i420EX /486DX33 /16MB /Trio64V+ /AZT2316
3) i430HX /P233MMX /64MB /VirgeDX+3Dfx /Vibra16s
4) i440BX /P II 400 /256MB /FX5500/AWE64
5) i865G /E5800 /2GB /Ti4200 /YMF724

Reply 385 of 440, by FreddyV

User metadata
Rank Member
Rank
Member

Ok, I see

I had this bug and I spent time to correct it, but it seems to not be gone completely....
I did not know where was the bug, I moved the Adlib code somewhere else to have it working again (Because I went back all the other changes and nothing corrected the problem)
I need to slow down DOSBOX to have the problem.

Not simple......
Edit: No, I am not able to reproduce it even if I reduce DosBox Speed, so the problem is still here; it maw come back one day or one other.
If you can find other "BAD" Files, so that I can find something in common between these files.

I Had the problem with CD2PART1.MOD and CD2PART4.MOD

Reply 386 of 440, by FreddyV

User metadata
Rank Member
Rank
Member
root42 wrote on 2020-04-09, 20:38:

Here is my test video:

DATAJACK.S3M crashes the player.

Thanks,
This one was simple, it is something that was never implemented, so it did never work.
We can skip a pattern in .S3M by adding Pattern Nb 254 in the sequence...

Reply 387 of 440, by zyga64

User metadata
Rank Member
Rank
Member
FreddyV wrote on 2020-04-10, 17:00:

If you can find other "BAD" Files, so that I can find something in common between these files.

Yes, bad files are also:
future dance (X-SONIC)
dessous le ciel (x-sonic)
Chariots Of Fire (HMW)

1) SCAMP /286@20 /4MB /TVGA9000C /CMI8330
2) i420EX /486DX33 /16MB /Trio64V+ /AZT2316
3) i430HX /P233MMX /64MB /VirgeDX+3Dfx /Vibra16s
4) i440BX /P II 400 /256MB /FX5500/AWE64
5) i865G /E5800 /2GB /Ti4200 /YMF724

Reply 388 of 440, by leileilol

User metadata
Rank l33t++
Rank
l33t++

I've had a weird problem with one transcription where two very portamento'd channels break on the first time and is okay later on a second playback. Wonder if that's also related

by the way, DOSBox is not for running Windows 9x

Reply 389 of 440, by digistorm

User metadata
Rank Newbie
Rank
Newbie

Some play routines don’t start playing a channel if the first note has a porta-to-note command. Maybe because it wants to know the original pitch that it should adjust. Scream Tracker just plays that note as if the desired pitch is already reached (if that makes sense).

Reply 390 of 440, by FreddyV

User metadata
Rank Member
Rank
Member
digistorm wrote on 2020-04-11, 07:19:

Some play routines don’t start playing a channel if the first note has a porta-to-note command. Maybe because it wants to know the original pitch that it should adjust. Scream Tracker just plays that note as if the desired pitch is already reached (if that makes sense).

Good point, Mod Master don't chech for this.
In players, we need to chech everything, even if it is supposed to be impossible 🙁

Reply 391 of 440, by FreddyV

User metadata
Rank Member
Rank
Member
zyga64 wrote on 2020-04-10, 19:35:
Yes, bad files are also: future dance (X-SONIC) dessous le ciel (x-sonic) Chariots Of Fire (HMW) […]
Show full quote
FreddyV wrote on 2020-04-10, 17:00:

If you can find other "BAD" Files, so that I can find something in common between these files.

Yes, bad files are also:
future dance (X-SONIC)
dessous le ciel (x-sonic)
Chariots Of Fire (HMW)

I will test them on the Amstrad 1640 and I will install a 386 as well to test, thanks.
Sometimes, modify the code "Reveal" a Bug that was already present, I suppose this is the case here as I checked almost all the code I added between the 2 Versions.

A not correctly init variable surely generate a big Loop. As I added the code that stop the replay if the partition and Mixing code is too slow, that is why it stops.

Edit: I am now able to reproduce the problem, it does not seems to be simple.... Code so complex things in ASM is not simple.

Reply 392 of 440, by leileilol

User metadata
Rank l33t++
Rank
l33t++
digistorm wrote on 2020-04-11, 07:19:

Some play routines don’t start playing a channel if the first note has a porta-to-note command.

Yeah before the actual notes start I've set porta speed on

by the way, DOSBox is not for running Windows 9x

Reply 393 of 440, by FreddyV

User metadata
Rank Member
Rank
Member
leileilol wrote on 2020-04-12, 00:34:
digistorm wrote on 2020-04-11, 07:19:

Some play routines don’t start playing a channel if the first note has a porta-to-note command.

Yeah before the actual notes start I've set porta speed on

Hi,

Do you know what I should do then ?
I suppose ignore the Tone Portamento and play it as if it was not there ?

Can you give me a link to a file example ?

By the way, I am happy to see Ppls I have never seen here before 😀

Reply 395 of 440, by FreddyV

User metadata
Rank Member
Rank
Member

Hi,

Release 19 is here, please forget the release 18 😀

14/04/2020 Beta 18
- Correct a bug in the FT2 Volume Commande Code, preventing some module to start (zyga64)
- S3M : Pattern nb 254 now ignored. DATAJACK.S3M (root42)
- Improved the error management code.

Thanks to the testers. Now, this release is supposed to be much more stable.

FreddyV

Attachments

  • Filename
    MODMXT18.zip
    File size
    150.8 KiB
    Downloads
    51 downloads
    File license
    Public domain

Reply 396 of 440, by FreddyV

User metadata
Rank Member
Rank
Member

Working on OPL2LPT Support 😀
And on internal variables rename + "MODM Sound System" Doc.

While I am writing this, I realize that After GLX Player, Carlos worked on on Galaxy Sound System and was hired by Epic.
I don't expect this, my code is obsolete 😀

Reply 397 of 440, by matze79

User metadata
Rank Oldbie
Rank
Oldbie

Hi,

whats the exact Commandline for Playing on Custom Dac ?
Can`t find in Readme..

i once used it but now i can`t remember..

Edit: /d:ioport

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer

Reply 398 of 440, by matze79

User metadata
Rank Oldbie
Rank
Oldbie

Works fine,

extended my Tandy Prototype by DAC IC, so finally it now plays also MOD files 😉
maybe it would be a nice Idea to make a Card with 8Bit FIFO, DAC and do a IRQ Driven Version.

protos.jpg
Filename
protos.jpg
File size
182.27 KiB
Views
120 views
File license
Fair use/fair dealing exception

EDIT:
There is a Bug in Custom DAC, if i set to 3BC it will show 268h

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer

Reply 399 of 440, by root42

User metadata
Rank Oldbie
Rank
Oldbie

Feature request: Can we maybe has Reality Adlib Tracker playback as well? The tracker comes with player sources, so I would figure it should be simple-ish to integrate, especially since S3M Adlib support is also back? (haven't tested that one yet)

YouTube and Bonus
80386DX@25 MHz, 8 MiB RAM, Tseng ET4000 1 MiB, SnarkBarker & BlasterBoard, PC MIDI Card + SC55 + MT32, XT CF Lite, OSSC