VOGONS


Reply 540 of 573, by MJay99

User metadata
Rank Newbie
Rank
Newbie

Just fyi:

I Just tried Ryan Cramer's 'The Passage of Time' (passtime.s3m): On my MODM b20 it falls apart right in the first pattern, line 22/23 (takes about 5 seconds per line after that) and recovers right at the end of that pattern (around line 60). The error comes back at pattern 4, line 10. It's the same on GUS and SB, while the track itself plays nicely on e.g. Cubic Player.

Reply 542 of 573, by FreddyV

User metadata
Rank Member
Rank
Member

Hi,

I do my best to release the new version this week end, whatever is its status. (If I don't break everything)
I finalized the tuning of .VGM replay and added TDYLPT as well (Sure 90% it works)

Still need to test on real Tandy / GUS / SB Hardware one more time to be sure.
I also would like to do a Tandy Video for #Septandy

😀

Reply 543 of 573, by matze79

User metadata
Rank l33t
Rank
l33t

ftp://ftp.dosreloaded.de/Modules/P/PRODIGY5.MOD

This file has some Pauses, seems something is not played correctly.
but i did not install the latest Version of MODM.

Maybe one of you can try it ? still have b18 on the 486..

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer

Reply 544 of 573, by FreddyV

User metadata
Rank Member
Rank
Member
MJay99 wrote on 2020-09-04, 12:37:

Just fyi:

I Just tried Ryan Cramer's 'The Passage of Time' (passtime.s3m): On my MODM b20 it falls apart right in the first pattern, line 22/23 (takes about 5 seconds per line after that) and recovers right at the end of that pattern (around line 60). The error comes back at pattern 4, line 10. It's the same on GUS and SB, while the track itself plays nicely on e.g. Cubic Player.

Hi,
I corected this bug. It was a problem in the partition loader (Took me some time to find..)

Reply 545 of 573, by FreddyV

User metadata
Rank Member
Rank
Member
matze79 wrote on 2020-09-11, 13:40:
ftp://ftp.dosreloaded.de/Modules/P/PRODIGY5.MOD […]
Show full quote

ftp://ftp.dosreloaded.de/Modules/P/PRODIGY5.MOD

This file has some Pauses, seems something is not played correctly.
but i did not install the latest Version of MODM.

Maybe one of you can try it ? still have b18 on the 486..

This one is simple, It use sample >64Kb and it is not supported.
This is supported and working on GUS Anyway > Go Buy a GUS 😀

Correct this will limit the performance too much and really really few module suffer from it.

Reply 546 of 573, by root42

User metadata
Rank Oldbie
Rank
Oldbie

Would be a possible fix to halve the samples and reduce the base note for that sample? But maybe it’s not worth fixing, as you said.

YouTube and Bonus
80486DX@33 MHz, 16 MiB RAM, Tseng ET4000 1 MiB, SnarkBarker & GUSar Lite, PC MIDI Card+X2+SC55+MT32, OSSC

Reply 547 of 573, by matze79

User metadata
Rank l33t
Rank
l33t
FreddyV wrote on 2020-09-11, 13:46:
This one is simple, It use sample >64Kb and it is not supported. This is supported and working on GUS Anyway > Go Buy a GUS :) […]
Show full quote
matze79 wrote on 2020-09-11, 13:40:
ftp://ftp.dosreloaded.de/Modules/P/PRODIGY5.MOD […]
Show full quote

ftp://ftp.dosreloaded.de/Modules/P/PRODIGY5.MOD

This file has some Pauses, seems something is not played correctly.
but i did not install the latest Version of MODM.

Maybe one of you can try it ? still have b18 on the 486..

This one is simple, It use sample >64Kb and it is not supported.
This is supported and working on GUS Anyway > Go Buy a GUS 😀

Correct this will limit the performance too much and really really few module suffer from it.

Bad..

Could it not be solved by enabling it only if EMS Memory is avaible ? (if memory is the issue)
or whats the exact issue ?
A MOD Player not playing all Mod files seems a bit ehhh... like a Car not driving on all roads.

Maybe its possible to do some sort of conversion ?

Last edited by matze79 on 2020-09-11, 18:08. Edited 1 time in total.

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer

Reply 548 of 573, by MJay99

User metadata
Rank Newbie
Rank
Newbie
FreddyV wrote on 2020-09-11, 13:42:

I corected this bug. It was a problem in the partition loader (Took me some time to find..)

Awesome, thanks a lot!

Reply 549 of 573, by FreddyV

User metadata
Rank Member
Rank
Member
matze79 wrote on 2020-09-11, 14:46:
Bad.. […]
Show full quote

Bad..

Could it not be solved by enabling it only if EMS Memory is avaible ? (if memory is the issue)
or whats the exact issue ?
A MOD Player not playing all Mod files seems a bit ehhh... like a Car not driving on all roads.

Maybe its possible to do some sort of conversion ?

It is not a problem of memory but code optimization needing to check the sample end and the segment end.

You know, a musician needing a sample as long as a pattern.... It it not anymore a real module.

Reply 550 of 573, by leileilol

User metadata
Rank l33t++
Rank
l33t++
matze79 wrote on 2020-09-11, 14:46:

A MOD Player not playing all Mod files seems a bit ehhh... like a Car not driving on all roads.

Welcome to the world of tracker music!!! There's been many shifting standards since .mod and then there's all those extra formats and their own shifting standards from ideal player behaviors, etc. and >64kb samples in a .mod is very much a non-standard (A lot of those old sampled up commercial song conversions had to cut a lot of chunks, for example). At least when I save .mods in MPT, it'll trim these samples appropriately

apsosig.png

Reply 551 of 573, by FreddyV

User metadata
Rank Member
Rank
Member
root42 wrote on 2020-09-11, 13:48:

Would be a possible fix to halve the samples and reduce the base note for that sample? But maybe it’s not worth fixing, as you said.

I know, but my time is better spent on something else 😀

Reply 552 of 573, by FreddyV

User metadata
Rank Member
Rank
Member

Hi,

Here it is, This version is 6Kb bigger than the previous one.

07/07/2020 Beta 21
Warning : Delete MODMXT.CFG as its format changed.

- OPL3: Increased the delay for OPL3 Write again (Bug on 486)
- MDA: Autodetect Monochrome text mode
- MDA: Corrected the display during replay in Hercule and MDA (Sinclair PC200)
- Gravis: Corrected the Sample Offset when > Sample size on the GUS. (Bug on PANIC.S3M)
- Bug fix for tone portamento when it is started with no note defined.
- S3M: The Sample cut when the pitch is too high was no more working. (Root42, bug on PANIC.S3M)
- S3M: Bug corrected in the pattern loader (MJay99, PASSTIME.S3M)
- .XM: Corrected a Loader problem, when too many comments are added in samples name.

- .VGM: read on OPL2 / OPL3 and Tandy Added
- Added OPLLPT Config menu and support (Not Tested)
- Added the Tandy chip Config menu and detection (PCJr, T1000 and DAC).
- TDYLPT Code Added (Provided by Benedikt)
- -t -tdylpt -opl2lpt and -opl3 arguments sent to SBGVM
- Various internal changes, for Pause during replay, display...
- The GUS Replay Frequency is now displayed in the Debug Menu. (F6)
- GUS Volume now change with the global menu volume (Keep it > 60%)

Filename
MODMXT21.zip
File size
219.65 KiB
Downloads
29 downloads
File license
Public domain

Reply 553 of 573, by root42

User metadata
Rank Oldbie
Rank
Oldbie

I just downloaded and ran the B21. Two things: The title still says b20 instead of b21.
Also, I can't select my TNDY sound card. Is the Tandy support exclusive to Tandy and PCJr machines?

EDIT: I tried to play the Monkey 2 sound track, but it complains that no OPL3 was found (I have an OPL2, and the site states the chip used was YM3812).

YouTube and Bonus
80486DX@33 MHz, 16 MiB RAM, Tseng ET4000 1 MiB, SnarkBarker & GUSar Lite, PC MIDI Card+X2+SC55+MT32, OSSC

Reply 554 of 573, by root42

User metadata
Rank Oldbie
Rank
Oldbie

Ok, I found out through the Tandy thread that I need to press TAB to configure it. I tried "Int 0c0h" (by the way: default is 000h, I had to press Space to change it) but no sound is produced. The card works fine with ZAKTE.EXE for example. So it's definitely working.

EDIT: I stand corrected. Zak Main Theme works. But Defender of the Crown theme doesn't (https://vgmrips.net/packs/pack/defender-of-th … rown-tandy-1000).

EDIT2: It wasn't the file, it was me restarting MODM. It seems the first time around the 0c0h doesn't get applied (remember: 000h was default). So I think that's a bug. First time setup of the Tandy doesn't apply.

YouTube and Bonus
80486DX@33 MHz, 16 MiB RAM, Tseng ET4000 1 MiB, SnarkBarker & GUSar Lite, PC MIDI Card+X2+SC55+MT32, OSSC

Reply 555 of 573, by FreddyV

User metadata
Rank Member
Rank
Member
root42 wrote on 2020-09-14, 09:32:

Ok, I found out through the Tandy thread that I need to press TAB to configure it. I tried "Int 0c0h" (by the way: default is 000h, I had to press Space to change it) but no sound is produced. The card works fine with ZAKTE.EXE for example. So it's definitely working.

EDIT: I stand corrected. Zak Main Theme works. But Defender of the Crown theme doesn't (https://vgmrips.net/packs/pack/defender-of-th … rown-tandy-1000).

EDIT2: It wasn't the file, it was me restarting MODM. It seems the first time around the 0c0h doesn't get applied (remember: 000h was default). So I think that's a bug. First time setup of the Tandy doesn't apply.

Ok, thanks 😀 As I always tested with a real tandy or DOSBOX in tandy mode, I did not found this.
(Already corrected, Added a " TDY_Port:=TDY_PortList[TDY_PortNb];" at the end of the function)

I wait that more Bugs are found to publish a correction.
If anybody can test with the TDYLPT or OPL2LPT and tell me.

For the monkey island music, it is definitely a bug in the music files.
For some of the music (Main theme and others) something is played on the channel 18 at the begining.
You can try in DOSBOX to See.
SBVGM detect them as OPL3 as Well.

Reply 556 of 573, by OPLx

User metadata
Rank Member
Rank
Member
root42 wrote on 2020-09-14, 08:10:

EDIT: I tried to play the Monkey 2 sound track, but it complains that no OPL3 was found (I have an OPL2, and the site states the chip used was YM3812).

It looks like only Introduction may have been dumped incorrectly. That can happen when an OPL3-based sound card is set using the special DOSBox build that writes out VGM data. The other files seem to be all right for OPL2 playback.

Reply 557 of 573, by root42

User metadata
Rank Oldbie
Rank
Oldbie

How annoying! 😀 Someone needs to dump that one again, and reupload! The intro is the best part!
I will try out with some other files tonight.

YouTube and Bonus
80486DX@33 MHz, 16 MiB RAM, Tseng ET4000 1 MiB, SnarkBarker & GUSar Lite, PC MIDI Card+X2+SC55+MT32, OSSC

Reply 558 of 573, by FreddyV

User metadata
Rank Member
Rank
Member
root42 wrote on 2020-09-15, 11:32:

How annoying! 😀 Someone needs to dump that one again, and reupload! The intro is the best part!
I will try out with some other files tonight.

It can be changed with a simple update, by modifying the header.

Reply 559 of 573, by root42

User metadata
Rank Oldbie
Rank
Oldbie

Really? I would have assumed that it also stores values for OPL3 registers that are not existent in the OPL2. Or does the VGM only contain register changes, which are all OPL2 for Monkey2?

EDIT: The change is to null 0x5c to 0x5E, which contains the OPL3 clock, and instead to set 0x50 to 0x52 to 99 9E 36, which is the OPL2 clock.

Attachments

Last edited by root42 on 2020-09-15, 20:25. Edited 1 time in total.

YouTube and Bonus
80486DX@33 MHz, 16 MiB RAM, Tseng ET4000 1 MiB, SnarkBarker & GUSar Lite, PC MIDI Card+X2+SC55+MT32, OSSC