VOGONS


Reply 40 of 54, by appiah4

User metadata
Rank l33t++
Rank
l33t++

Works fairly well in my P3-1200 / GeForce 3 Ti 200 / DX9 PC but ever since upgrading from a P3-700 / GeForce 2 GTS / DX7a I get noticable texture corruption in places; is this a known and reported behaviour?

Retronautics: A digital gallery of my retro computers, hardware and projects.

Reply 41 of 54, by SpectriaForce

User metadata
Rank Oldbie
Rank
Oldbie
Tsukiouji wrote:

Beware of the `fast CPU texture LOD bug` which kicks in (afair) after ~1GHz and going really wild at 2GHz+. There are patches to fix that.
Btw, I wholeheartedly recommend to patch NFS:PU extensivly with now-tried and available community patches, like "NFS5 Essentials" which fixes alot of car parts too.

My game is already patched with all available updates that make sense for my setup (also for graphical bugs). It would otherwise crash after an x amount of hours of use at the start game screen (which was really annoying back in the day when I didn't have a patch).

I haven't tested this game any further yet (fully completed evolution mode and now I'm bored with it 😊 ). I still use the same pc with the same graphics card. There's not much else that I can test. Maybe a beast like a GF6800 Ultra and a Tualatin PIII could give me some additional frames or maybe I should downgrade to something more period correct like a GF256 / TNT2 Ultra 😊

I sell 'ridiculously expensive' retro hardware to people like you. I feel sorry for that.

Reply 42 of 54, by rfratelli

User metadata
Rank Newbie
Rank
Newbie

Recently I've put together a retro pc and the only game I'm unable to run is NFS Porsche. Such a great game!

I have a win98SE / Semprom 2600+ 1600MHz / 256GB RAM with Geforce 6200 128mb AGP.

Game shows intro movie and crashes to desktop right after splash screen ( I don't even get to the menus). Tried to revert to dx7.0a, old Nvidia drivers (4.14.10.8185) but nothing seems to work.

Any suggestions?

Reply 43 of 54, by cyclone3d

User metadata
Rank l33t++
Rank
l33t++

What, if any updates have you installed for Windows?

Please don't say the unofficial SP3 as the newer versions are absolute trash.

Yamaha YMF modified setupds and drivers
Yamaha XG resource repository - updated November 27, 2018
Yamaha YMF7x4 Guide
AW744L II - YMF744 - AOpen Cobra Sound Card - Install SB-Link Header
Epstein didn't kill himself

Reply 44 of 54, by rfratelli

User metadata
Rank Newbie
Rank
Newbie
cyclone3d wrote on 2021-04-01, 04:20:

What, if any updates have you installed for Windows?

Please don't say the unofficial SP3 as the newer versions are absolute trash.

I don't think i've got SP3. I guess i just did a plan win98SE install and updated it with IE6.
Mine shows Microsoft Windows 98 (4.10, Build 2222) A

Attachments

  • win98.jpg
    Filename
    win98.jpg
    File size
    1.55 MiB
    Views
    280 views
    File comment
    win98 version
    File license
    CC-BY-4.0

Reply 45 of 54, by rfratelli

User metadata
Rank Newbie
Rank
Newbie

Ok I've tried everything I could under win98, but the game does not work. Best I could get was at initial menu but with no characters and no clickable buttons (that was using verokster's patch).

So I've installed winxp sp3 on the same computed (now I have dual boot 😀 ) and it works just fine under winxp! go figure...

Reply 46 of 54, by kjliew

User metadata
Rank Oldbie
Rank
Oldbie
rfratelli wrote on 2021-04-05, 03:36:

Ok I've tried everything I could under win98, but the game does not work. Best I could get was at initial menu but with no characters and no clickable buttons (that was using verokster's patch).

If you were running the game under Win98, then no 3rd-party patch was ever needed. Perhaps using such patch was the cause of your trouble as the patch was meant to fix the game on Windows XP+.

The last Win98 driver for GeForce 6 wasn't that great either. There were other posts here in VOGONS (if you did a search) that it broke compatibility with old DirectX games such as NFS Porsche and Mafia on Win98. You can either check out older drivers or use other more compatible Win98 GPUs, such as GeForce FX.

Reply 47 of 54, by rfratelli

User metadata
Rank Newbie
Rank
Newbie

Yes I've tried some older drivers (from Phil computer labs website). No luck. I wasn't using the patch in first place I just tried the patch when It did not worked out of the box.
Must be some kind of VGA compatibility issue because I remember running it under win98 back then, I just don't recall on which hardware.

Anyway, such a great game!

Reply 48 of 54, by kjliew

User metadata
Rank Oldbie
Rank
Oldbie

Yeah, it is a great game.

With modern virtualization, the performance of playing the game on VM on modern system (incl. laptops) simply outclass anything that is less than GeForce 6600 GPUs.
https://www.youtube.com/watch?v=R3hm9bPOM84

You can also get 3rd-party OpenGL 3rash driver if that will work better on your GeForce 6200. The link is in the description on the YouTube video.

Reply 49 of 54, by bloodem

User metadata
Rank Oldbie
Rank
Oldbie
rfratelli wrote on 2021-04-05, 03:57:

Yes I've tried some older drivers (from Phil computer labs website). No luck. I wasn't using the patch in first place I just tried the patch when It did not worked out of the box.
Must be some kind of VGA compatibility issue because I remember running it under win98 back then, I just don't recall on which hardware.

Anyway, such a great game!

Your issue is without a question related to the video card. A GeForce 6200 is not suitable for a Win98 build, its drivers break compatibility with many games.
In my experience, the fastest video card that still works with NFS 5 Porsche in Win98 is the Radeon X800XT/X850XT
You don't need this video card, though, unless you want to play at very high resolutions with AA & AF. Also, it should be noted that the NFS5 frametimes are all over the place even with the fastest hardware possible (game engine limitation).
Here's some graphs that I made a few months ago (tested on a Pentium Dual Core E5800 @ 3.8 GHz). You can decide which video card is best for you, depending on the resolution you want to play at.
As it can be seen, the GeForce 6600GT did not work with this game, even when using the most compatible drivers that I could find.

Attachments

  • NFS5_1024x768x32.png
    Filename
    NFS5_1024x768x32.png
    File size
    41.57 KiB
    Views
    226 views
    File license
    Fair use/fair dealing exception
  • NFS5_1600x1200x32.png
    Filename
    NFS5_1600x1200x32.png
    File size
    39.72 KiB
    Views
    226 views
    File license
    Fair use/fair dealing exception

2 x PGA132 / 5 x Socket 3 / 4 x Socket 7 / 6 x Super Socket 7 / 5 x Slot 1 / 3 x Slot A
5 x Socket 370 / 5 x Socket A / 1 x Socket 478 / 2 x Socket 754 / 3 x Socket 939 / 4 x LGA775 / 1 x LGA1155
Current rig: Ryzen 5 3600X
Backup rig: Core i7 7700k

Reply 50 of 54, by aha2940

User metadata
Rank Member
Rank
Member

Hi!

I am having a strange (for me) issue with NFS5: Porsche unleashed. It will start without any issues, then at the menus it will freeze. The music keeps playing, but the mouse pointer will not move and no keyboard combination (Ctrl-Alt-Del, Alt+F4, etc.) will work. However, if I eject the CDROM and leave it open, there is a very high possibility that the game will resume working, however this lasts only a few minutes, then it freezes again. If I reinsert the CDROM the game may work again, but sometimes it does not. Now the technical data:

CPU: Pentium 4 @ 2.4GHz
Mobo: Intel D845GEBV2
Video card: nVidia Geforce 2 MX400, driver version 45.23
Soundcard: Soudblaster Live! SB0100
OS: Windows 98SE without any patches (just DirectX updated to DX8 IIRC)

The game is installed from the original CD, it was updated to latest version 3.5 but issue persists

Any ideas are appreciated. Thanks!

Reply 52 of 54, by aha2940

User metadata
Rank Member
Rank
Member
Warlord wrote on 2021-04-06, 18:22:

For 6 series nv gpu u need use glide wrapper bcus gpu is too new

Already tried that for other games (NFS2SE and POD) however I have not found a decent glide wrapper that works with DirectX 7 (max version supported by my video card). I tried dgvoodoo 1.40.and 1.50, but they crash on start. Any suggestions on which one to try?

Reply 53 of 54, by rfratelli

User metadata
Rank Newbie
Rank
Newbie
bloodem wrote on 2021-04-05, 05:18:
Your issue is without a question related to the video card. A GeForce 6200 is not suitable for a Win98 build, its drivers break […]
Show full quote
rfratelli wrote on 2021-04-05, 03:57:

Yes I've tried some older drivers (from Phil computer labs website). No luck. I wasn't using the patch in first place I just tried the patch when It did not worked out of the box.
Must be some kind of VGA compatibility issue because I remember running it under win98 back then, I just don't recall on which hardware.

Anyway, such a great game!

Your issue is without a question related to the video card. A GeForce 6200 is not suitable for a Win98 build, its drivers break compatibility with many games.
In my experience, the fastest video card that still works with NFS 5 Porsche in Win98 is the Radeon X800XT/X850XT
You don't need this video card, though, unless you want to play at very high resolutions with AA & AF. Also, it should be noted that the NFS5 frametimes are all over the place even with the fastest hardware possible (game engine limitation).
Here's some graphs that I made a few months ago (tested on a Pentium Dual Core E5800 @ 3.8 GHz). You can decide which video card is best for you, depending on the resolution you want to play at.
As it can be seen, the GeForce 6600GT did not work with this game, even when using the most compatible drivers that I could find.

Awesome, thanks for the info! Yeah i just had this card laying around and decided to use it anyways. Worked fine under winxp!

Reply 54 of 54, by rfratelli

User metadata
Rank Newbie
Rank
Newbie
aha2940 wrote on 2021-04-07, 04:26:
Warlord wrote on 2021-04-06, 18:22:

For 6 series nv gpu u need use glide wrapper bcus gpu is too new

Already tried that for other games (NFS2SE and POD) however I have not found a decent glide wrapper that works with DirectX 7 (max version supported by my video card). I tried dgvoodoo 1.40.and 1.50, but they crash on start. Any suggestions on which one to try?

I'l suggest you do as i did, install winxp on it!

easy2boot is your friend. Use it to create a bootable usb.