VOGONS


First post, by Raymond C. Glassford

User metadata
Rank Newbie
Rank
Newbie

I am running DOSBox 0.72, self-compiled, under Mandriva Linux 2007.0, kernel 2.6.17-5mdv, and am experiencing sound stuttering when running all MS-DOS games. Sound is normal in other Linux applications. I found a thread discussing the topic of sound stuttering when using the Linux version of DOSBox 0.61, and which further recommends removing some lines from source code before compiling.

This is taken from Unavowed's post:

==================================================
START OF QUOTE
==================================================
I ran into the same problem, using Gentoo with kernel 2.4.24-ow1. I managed to fix it by removing some lines from MIXER_Mix() in src/hardware/mixer.cpp. I tried to understand how this mixer thing works and create a decent fix but it would take too much time as the source is lacking comments or it's just me being too little of a coder, never mind. Removing these lines alone makes it work fine for me and that's all that matters.

If you decide to do the same, the lines are 215-217. Code:

Bitu size=MIXER_BUFSIZE+mixer.out.write-mixer.out.read;
if (size>=MIXER_BUFSIZE) size-=MIXER_BUFSIZE;
if (size>mixer.blocksize*2) return;
==================================================
END OF QUOTE
==================================================

I am wondering if this Linux sound stuttering problem is being actively addressed and will be resolved in the release of the next DOSBox version. If so, I will wait patiently. If not, I will try this coding fix on a fresh install, after I have worked on some "projects" of higher priority.

Other than the sound stuttering problem, DOSBox 0.72 provides excellent performance with Doom, Doom II, Heretic, Hexen, Deathkings of the Dark Citadel (Hexen add-on), Strife, and 11th Hour.

--------------------------------------------------
Compaq Deskpro EN, Pentium III 933 MHz, 256 MB RAM, Nvidia Riva TNT2 AGP Card, Canon BJC-610 Printer, Best Data 56SX92 External Serial Modem, Mandriva 2007.0, kernel 2.6.17-5mdv, KDE 3.5.4, DOSBox 0.72
--------------------------------------------------

Reply 1 of 10, by MiniMax

User metadata
Rank Moderator
Rank
Moderator

Several of the DOSBox developers are themselves running and developing DOSBox on Linux, with cross-compiles to produce the Windows version, so if this was a general problem I am sure it would have been solved a long time ago. Sounds more like a problem with your build, or with Mandrive.

Can you run one of the official builds?

DOSBox 60 seconds guide | How to ask questions
_________________
Lenovo M58p | Core 2 Quad Q8400 @ 2.66 GHz | Radeon R7 240 | LG HL-DT-ST DVDRAM GH40N | Fedora 32

Reply 2 of 10, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

or running DOS games in DosBox on a P3 when the games he listed have Linux ports..... (except of course for 11th hour)

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 3 of 10, by Raymond C. Glassford

User metadata
Rank Newbie
Rank
Newbie
MiniMax wrote:

Several of the DOSBox developers are themselves running and developing DOSBox on Linux, with cross-compiles to produce the Windows version, so if this was a general problem I am sure it would have been solved a long time ago. Sounds more like a problem with your build, or with Mandrive.

Can you run one of the official builds?

DOSBox 0.65 is available as a Mandriva 2007.0 package. I can give that a try. I will not be upgrading my Mandriva distro at least until 2008.1 is released.

Thanks for your comments.

Reply 4 of 10, by MiniMax

User metadata
Rank Moderator
Rank
Moderator

Ahh - didn't see that:

Pentium III 933 MHz, 256 MB RAM

Try lowering CPU-cycles, increasing framskip.

DOSBox 60 seconds guide | How to ask questions
_________________
Lenovo M58p | Core 2 Quad Q8400 @ 2.66 GHz | Radeon R7 240 | LG HL-DT-ST DVDRAM GH40N | Fedora 32

Reply 5 of 10, by Qbix

User metadata
Rank DOSBox Author
Rank
DOSBox Author

well i have no sound stuttering with 0.7x
I advise you to update to that. The mixer routines have changed and improved a lot since 0.61 which is way too old for us to care about sound stuttering anymore.

You might want to play with the configuration settings of dosbox. blocksize and prebuffer.

Water flows down the stream
How to ask questions the smart way!

Reply 6 of 10, by Raymond C. Glassford

User metadata
Rank Newbie
Rank
Newbie
Qbix wrote:

well i have no sound stuttering with 0.7x
I advise you to update to that. The mixer routines have changed and improved a lot since 0.61 which is way too old for us to care about sound stuttering anymore.

You might want to play with the configuration settings of dosbox. blocksize and prebuffer.

I recall that I did do some experimenting with blocksize and prebuffer. I believe I also tried adjusting cycles and frameskip just after I did the install. No luck.

As DosFreak pointed out, using a Pentium 3 CPU is a definite handicap and might be the ultimate limiting factor in the whole equation. Graphics are acceptably fluid, however, although not as fluid for all games I mentioned when they were run on my now-discarded AST 486DX2-66MHz unit.

Reply 7 of 10, by Pix

User metadata
Rank Newbie
Rank
Newbie

Hello folks,

I am experiencing the same problem.

When I start dosbox without any parameters, I get on the console:
michael@slovakia:~/dos$ dosbox
DOSBox version 0.72
Copyright 2002-2007 DOSBox Team, published under GNU GPL.
---
CONFIG:Loading primary settings from config file dosbox.conf
Maximum memory size is 63 MB
ALSA:Client initialised [129:0]
MIDI:Opened device:alsa
MAPPER: Loading mapper settings from mapper.txt

I also had OSS output first because timidity was not running and I was wondering if it could be the problem. It wasnt.

I have to say, that on Windows 7 it runs properly and I have no sound problems at all, the game seems to run without any stuttering.

What could be the the problem? Pulseaudio perhaps?

I'm really out of ideas here and would be glad if I hadn't to switch to Windows everytime i want to play a great game 😀

And I don't seem to be the only one with this stuttering. Every other application works perfectly fine.

Any help is welcome.

€dit: Before I forget, I run Ubuntu 9.04 and I tried self-compiled dosbox from CVS (yesterday) and the ubuntu package (0.72build1), both have the same problems, so I think it might be a design flaw within dosbox or with the linux audio system.

Last edited by Pix on 2009-06-13, 23:29. Edited 1 time in total.

Reply 8 of 10, by Kippesoep

User metadata
Rank Oldbie
Rank
Oldbie

Please don't resurrect year old threads for this. There's been some discussion lately and Pulseaudio does appear to have some problems. Have you tried disabling it?

My site: Ramblings on mostly tech stuff.

Reply 9 of 10, by Pix

User metadata
Rank Newbie
Rank
Newbie

Yes I did (wow, that was fast answer).

Sorry, if I am resurrecting an old thread, but I wasn't able to find anything else.

Just tried to deactivate pulseaudio and got the same situation.

I wonder what's wrong. My kernel is btw michael@slovakia:~/dos$ uname -a
Linux slovakia 2.6.28-13-generic #44-Ubuntu SMP Tue Jun 2 07:57:31 UTC 2009 i686 GNU/Linux

Not self compiled.
Currently, my test situation is the intro of REALMS OF THE HAUNTING (in Windows & Linux), in Windows it works fine... the other one stutters, even though configuration is completely ok it seems. My dosbox.conf file adjusts to the game conf.

---------

JUST SOLVED THE PROBLEM!
blocksize=4096
prebuffer=1000

I expected the buffer to be too low on linux. So I set it on 4096 instead of 2048 and prebuffer on 1000 (from 10, may be a bit overrated..).

Anyway, it works.

Sorry for bothering, but I can recommend anyone with stuttering this.. the ultimate solution for me. 😀