VOGONS


First post, by keropi

User metadata
Rank l33t++
Rank
l33t++

I just got an error from a game that I don't have enough conventional memory 😳 ... it was a shock to me because I had 600+ kb free in any configuration... so I looked and it appears that my UMB blocks died or something???

here is what I was getting, for an EMS config:

Modules using memory below 1 MB: 

Name Total Conventional Upper Memory
-------- ---------------- ---------------- ----------------
MSDOS 16,752 (16K) 16,752 (16K) 0 (0K)
HIMEM 1,120 (1K) 1,120 (1K) 0 (0K)
EMM386 4,320 (4K) 4,320 (4K) 0 (0K)
CDROM 5,072 (5K) 0 (0K) 5,072 (5K)
COMMAND 7,296 (7K) 0 (0K) 7,296 (7K)
MSCDEX 28,032 (27K) 0 (0K) 28,032 (27K)
CTMOUSE 3,584 (4K) 0 (0K) 3,584 (4K)
Free 681,680 (666K) 632,912 (618K) 48,768 (48K)

Memory Summary:

Type of Memory Total Used Free
---------------- ----------- ----------- -----------
Conventional 655,360 22,448 632,912
Upper 92,752 43,984 48,768
Reserved 393,216 393,216 0
Extended (XMS)* 65,967,536 578,992 65,388,544
---------------- ----------- ----------- -----------
Total memory 67,108,864 1,038,640 66,070,224

Total under 1 MB 748,112 66,432 681,680

Total Expanded (EMS) 33,947,648 (32M)
Free Expanded (EMS)* 33,554,432 (32M)

* EMM386 is using XMS memory to simulate EMS memory as needed.
Free EMS memory may change as free XMS memory changes.

Largest executable program size 632,896 (618K)
Largest free upper memory block 48,560 (47K)
Available space in High Memory Area 1,040 (1K)
MS-DOS is resident in the high memory area.

and.... here is what I get NOW , 0kb of UMB in EMS or XMS configs... even UMBPCI that loads fine does not make available UMB blocks anymore... 😵 😵 😵

Modules using memory below 1 MB:

Name Total Conventional Upper Memory
-------- ---------------- ---------------- ----------------
MSDOS 14,304 (14K) 14,304 (14K) 0 (0K)
HIMEM 1,120 (1K) 1,120 (1K) 0 (0K)
EMM386 4,320 (4K) 4,320 (4K) 0 (0K)
COMMAND 7,440 (7K) 7,440 (7K) 0 (0K)
MSCDEX 28,032 (27K) 28,032 (27K) 0 (0K)
CTMOUSE 3,584 (4K) 3,584 (4K) 0 (0K)
Free 565,920 (553K) 565,920 (553K) 0 (0K)

Memory Summary:

Type of Memory Total Used Free
---------------- ----------- ----------- -----------
Conventional 655,360 89,440 565,920
Upper 0 0 0
Reserved 393,216 393,216 0
Extended (XMS)* 66,060,288 671,744 65,388,544
---------------- ----------- ----------- -----------
Total memory 67,108,864 1,154,400 65,954,464

Total under 1 MB 655,360 89,440 565,920

Total Expanded (EMS) 33,947,648 (32M)
Free Expanded (EMS)* 33,554,432 (32M)

* EMM386 is using XMS memory to simulate EMS memory as needed.
Free EMS memory may change as free XMS memory changes.

Largest executable program size 565,888 (553K)
Largest free upper memory block 0 (0K)
MS-DOS is resident in the high memory area.

I have NO idea why this happens! I have not edited my config/autoexec , infact I am attaching them here... ems or xms configs make no difference, even UMBPCI.SYS that used to work does nothing now??!?!?!

Because of that I suspect I did something on BIOS that I cannot remember and I just cannot find it now.... take a look on the screens:

th_IMG00313-20101223-0059.jpg

th_IMG00317-20101223-0103.jpg

th_IMG00318-20101223-0103.jpg

th_IMG00320-20101223-0103.jpg

th_IMG00321-20101223-0104.jpg

th_IMG00322-20101223-0104.jpg

th_IMG00323-20101223-0104.jpg

on the Standard CMOS Setup screen I can see the 384kb of "other mem" but the part of it I was using is now gone... I can't for the life of me figure out why???! There where no hardware changes, no software ones IIRC...

Can anyone pinpoint the problem?
Thanks! 😁

Attachments

  • Filename
    auto-conf.zip
    File size
    1.24 KiB
    Downloads
    178 downloads
    File comment
    autoexec.bat and config.sys
    File license
    Fair use/fair dealing exception
Last edited by keropi on 2010-12-23, 06:50. Edited 1 time in total.

🎵 🎧 PCMIDI MPU , Orpheus Soundcard , Action Rewind and Megacard website

💻 WTB Amstrad PC7486SLC-33

Reply 2 of 8, by keropi

User metadata
Rank l33t++
Rank
l33t++

those shadow/caching options made no difference... About a month ago I removed my AGP riva128 card, put a pci riva - updated it's BIOS and put the agp card back... Also I change an old cd-rom with a dvd rom but I don't see the cd->dvd drive to have anything to do with UMB's...

I also did a load bios/setup defaults, no change either... 😒
I wonder if I need to make a complete BIOS reset via it's battery...

🎵 🎧 PCMIDI MPU , Orpheus Soundcard , Action Rewind and Megacard website

💻 WTB Amstrad PC7486SLC-33

Reply 3 of 8, by keropi

User metadata
Rank l33t++
Rank
l33t++

an update: it is not bios settings or anything... I have installed on a 2nd HDD my DOS setup and now I get UMB's... I don't get what has changed though and I get no UMB's on my current setup... ?? I did not mess with any system files unless something else tampered with them...
I have no idea why is this and this is very confusing 😖 😳

edit:

I took my HDD out of the p200mmx machine and put it on my win7 one... loaded windows and performed a scan with kaspersky... guess what? yep that's right I had a virus! A bastard called Virus.DOS.Major.1644 , even mem.exe from my old dos setup was infected... almost everything that run after the carrier program was infected... luckily KAV disinfected the files 😊
I should have manually checked the stuff through KAV instead of just copying to my dos machine 😵

🎵 🎧 PCMIDI MPU , Orpheus Soundcard , Action Rewind and Megacard website

💻 WTB Amstrad PC7486SLC-33

Reply 5 of 8, by keropi

User metadata
Rank l33t++
Rank
l33t++

luckily this virus is nothing special and did no damage.... lesson learned !

🎵 🎧 PCMIDI MPU , Orpheus Soundcard , Action Rewind and Megacard website

💻 WTB Amstrad PC7486SLC-33

Reply 6 of 8, by Amigaz

User metadata
Rank Oldbie
Rank
Oldbie

Yikes!

*Amigaz considers using NOD32DOS on his armada of DOS machines* 😈

My retro computer stuff: https://lychee.jjserver.net/#16136303902327

Reply 7 of 8, by keropi

User metadata
Rank l33t++
Rank
l33t++

Amigaz, look on the DOS antivirus thread, I am gonna write how to make an up-to-date nod32dos install...

🎵 🎧 PCMIDI MPU , Orpheus Soundcard , Action Rewind and Megacard website

💻 WTB Amstrad PC7486SLC-33

Reply 8 of 8, by Amigaz

User metadata
Rank Oldbie
Rank
Oldbie
keropi wrote:

Amigaz, look on the DOS antivirus thread, I am gonna write how to make an up-to-date nod32dos install...

Arighty, thanks 😀

My retro computer stuff: https://lychee.jjserver.net/#16136303902327