First post, by joeljoel1947

User metadata
Rank Newbie

So after a lot of work, and thanks to member "Stick" here, I have FINALLY gotten my old DOS version of Oldtime Baseball to run in windows 8.1 via DOSBox without the cd needing to be in my drive whilst playing! Yay! That in itself took a good few days of work for me, so a relative newb here. It's a difficult game to get going as it really demands a cd to be in your cd drive. If not---no game for you!

Crazy new problem has now surfaced in the aftermath of my new found glory---- My controller in dosbox now has a mind of its own. When I was loading off the cd in DOSBox, it worked fine, the controller was the least of my worries. Controller worked perfect (Logitech F310).

But NOW, sans CD, the controller really wants to only go up and left. Down and right just don't happen. I have tried both my Logitech analog/digital F310 gamepad and my iBuffalo classic USB gamepad and they both really only acknowledge 2 of the 4 axis----up and right.

My question is, even after trying 50 times to calibrate the thing in the Oldtime baseball setup, is there some calibration I am missing in DOSBOX that may be overriding what I am doing within the actual game?

Two mysteries have also emerged---
1) The game now "auto-detects" TWO gamepads when it loads (with only one plugged in) so I tell it to "disable gamepad 2" which is an option
2) When the game actually loads, even though I have disabled the 2nd gamepad it automatically is defaulting to a 2 player game and selecting 2 gamepads as if they are both "there"

I feel as if something to deal with that 2nd gamepad it detects might be the thing only limiting 2 axis on the 1st gamepad. Bizarre stuff.

Any help from anyone? May be something major I'm missing. Literally the 1st thing I've ever tried to run in DOSBOX just because computers now out date (in a positive way) my old DOS game.

Thanks all!


Reply 1 of 4, by Osprey

User metadata
Rank Member

Have you fiddled with the settings in the [joystick] section in your DOSBox .conf file? If you don't have one, add the following and then fiddle with the settings:

# joysticktype: Type of joystick to emulate: auto (default), none,
# 2axis (supports two joysticks),
# 4axis (supports one joystick, first joystick used),
# 4axis_2 (supports one joystick, second joystick used),
# fcs (Thrustmaster), ch (CH Flightstick).
# none disables joystick emulation.
# auto chooses emulation depending on real joystick(s).
# (Remember to reset dosbox's mapperfile if you saved it earlier)
# Possible values: auto, 2axis, 4axis, 4axis_2, fcs, ch, none.
# timed: enable timed intervals for axis. Experiment with this option, if your joystick drifts (away).
# autofire: continuously fires as long as you keep the button pressed.
# swap34: swap the 3rd and the 4th axis. can be useful for certain joysticks.
# buttonwrap: enable button wrapping at the number of emulated buttons.


Try playing with the top two options.

Reply 3 of 4, by joeljoel1947

User metadata
Rank Newbie

Osprey you are a legend! Went into that joystick config area and THIS option below was defaulted to TRUE in DOSBOX:

timed: enable timed intervals for axis. Experiment with this option, if your joystick drifts (away).

Hence why I could probably only go up and left ( they are the first 2 axis you set in the actual joystick config in game during setup). Anyhow, I've now Set that crazy timing intervals thing to FALSE and now I get all 4 axis to work! Plays perfect now!

Thanks again!!!!