VOGONS


First post, by cyclone3d

User metadata
Rank l33t++
Rank
l33t++

I am having trouble getting sound working on Halloween Harry (Alien Carnage) - freeware edition.

I figured I may need to have IO at 220 and IRQ at 7 and DMA at 1.

Per 3DRealms I was correct, except IRQ can be at either 5 or 7.
http://legacy.3drealms.com/tech/aliencarnage.html

With a Tropez+, the game loads but then hangs when I tell it to start a new game.

With a Sound Blaster Pro (dual OPL2), it hangs when trying to load the game.

I've tried both IRQ 5 and 7. No difference.

Should I try a different card? I don't see why this game in particular is having an issue when none of the other games I have tested on that system have issues with sound.

Yamaha YMF modified setupds and drivers
Yamaha XG resource repository - updated November 27, 2018
Yamaha YMF7x4 Guide
AW744L II - YMF744 - AOpen Cobra Sound Card - Install SB-Link Header
Epstein didn't kill himself

Reply 1 of 1, by cyclone3d

User metadata
Rank l33t++
Rank
l33t++

Got it figured out...

I thought maybe it had something to do with the freeware release so I installed the 1994 registered release of the game in a different folder and it worked fine.

Decided to go ahead and try copying over the freeware release again, which I download directly from 3DRealms this time and it also worked.

Must have either been a bad copy I had before or it didn't copy over properly the first time.

Yamaha YMF modified setupds and drivers
Yamaha XG resource repository - updated November 27, 2018
Yamaha YMF7x4 Guide
AW744L II - YMF744 - AOpen Cobra Sound Card - Install SB-Link Header
Epstein didn't kill himself