VOGONS


First post, by Tenome

User metadata
Rank Newbie
Rank
Newbie

I'm trying to setup an old Japanese PC game with dgVooDoo 2.75.1 so that I can play it in a forced windowed mode, with a machine translator on the side. I have the MS x86 files in the folder since it's an old DirectDraw game. However, I've encountered one minor glitch so far, in that the sprites for the spell animations are replaced with a black texture. The game runs fine without dgVooDoo (but forces itself into fullscreen), so something with DGVD is causing this issue. Any ideas what might cause a missing texture? Here are my settings.
https://ghostbin.com/paste/YI6cU
I'm on Windows 7, AMD Radeon 570, intel i5 2500k if that matters (probably doesn't).

The result:

Vampire Hurts-2021-09-06-21-44-15.png
Filename
Vampire Hurts-2021-09-06-21-44-15.png
File size
458.97 KiB
Views
329 views
File license
CC-BY-4.0

Thanks for any help.

Attachments

Reply 2 of 4, by Tenome

User metadata
Rank Newbie
Rank
Newbie
Dege wrote on 2021-09-09, 09:15:

It must be a dgVoodoo bug, I guess. Can I download this game from somewhere?

Btw, are you using the WARP renderer because you get white textures otherwise?

You can grab it from Archive.org. And yeah I'm using WARP because the entire backrgound renders as a white void otherwise (though like I said, the game runs perfectly fine without it, but then I can't run it in a window). Here's what the gameplay window setup looks like.
https://www.youtube.com/watch?v=EughFl-p1LM

Reply 3 of 4, by Dege

User metadata
Rank l33t
Rank
l33t

I had a look at it and it turned out that it's not a dgVoodoo bug after all.
Some part of the bitmap transparency lookup tables in the game needs the display mode to be set to 16 bit (but dgVoodoo always renders in 32 bit). This is a typical problem with other games as well.

You can easily fix this on Win10 by setting forced 16 bpp in the app compatibility properties but it's not a viable way on Win7 (you can only set the display mode bit depth system wide).
So, I quickly made a little patch for that:

http://dege.fw.hu/temp/vh_16_bpp_fix.zip

I think it's very unfortunate for you to run this game on Win7. White textures are because of the known AMD D3D11 issue.
On Win10 at least you would have D3D12 so you could run it through hw acceleration instead of the slow WARP device + that patch wouldn't be needed.

Btw, 'fast vidmem access' is not needed for this game, I also found something to fix regarding that, I'll look into that later.

Reply 4 of 4, by Tenome

User metadata
Rank Newbie
Rank
Newbie
Dege wrote on 2021-09-16, 15:20:
I had a look at it and it turned out that it's not a dgVoodoo bug after all. Some part of the bitmap transparency lookup tables […]
Show full quote

I had a look at it and it turned out that it's not a dgVoodoo bug after all.
Some part of the bitmap transparency lookup tables in the game needs the display mode to be set to 16 bit (but dgVoodoo always renders in 32 bit). This is a typical problem with other games as well.

You can easily fix this on Win10 by setting forced 16 bpp in the app compatibility properties but it's not a viable way on Win7 (you can only set the display mode bit depth system wide).
So, I quickly made a little patch for that:

http://dege.fw.hu/temp/vh_16_bpp_fix.zip

I think it's very unfortunate for you to run this game on Win7. White textures are because of the known AMD D3D11 issue.
On Win10 at least you would have D3D12 so you could run it through hw acceleration instead of the slow WARP device + that patch wouldn't be needed.

Btw, 'fast vidmem access' is not needed for this game, I also found something to fix regarding that, I'll look into that later.

Interesting, the more you know. It seems to work. Thanks for the fix! And yeah, I still haven't moved to W10 yet -- my main concern was actually that it would be harder to run older games on W10...