Common searches

First post, by mzry

User metadata
Rank Member

Hi all,

Not sure why but completely randomly Deus Ex (original GOTY) has started crashing on save, whether I press quick save or try to go into the save menu the entire machine freezes with a sound screech.

I know what you're thinking, sound drivers etc! But no, here is what I have tried:

* Removed my save folder in-case there was a corrupted save, just tried new game > tried saving on the docks, same issue
* Swapped sound cards to rule out issues, still locks up
* Removed sound card entirely and ran game without sound, still locks up
* Changed rendering device from Glide to D3D, still locks up
* Changed sound driver device (in game) still locks up
* Re-installed the game entirely, still locks up
- So after all this I am thinking, must be an OS issue? So I play some other unreal engine games, everything seems fine.
* Tried some Deus Ex community patches, still locks up
.... Ok now I'm thinking it has to be hardware?
I swap from using my IDE CF Card game drive, copied the game to C:\ which is Adaptec SCSI, still the game locks on save, so it isn't a dodgy CF card...

Win2k fully patched to SP5 & other community patches
P3 1.4Ghz Tualatin
Asus TUSL2-C Mobo (fully re-capped)
3dfx PCI 5500 graphics (fully re-capped)
X-Fi sound card
Adaptec SCSI, 36gb Fujitsu 15krpm drive

Some other hardware things I tried:
Resetting bios to defaults
Upping CPU voltage by .50mv
Putting SD-RAM driving on 'strong'
Changing high priority PCI to enabled/disabled
Removing power cables from floppy, dvd-rom just to put less load on the PSU

I'm out of ideas! This just started happening totally randomly! All I can think of doing now is re-installing the OS and starting from scratch... but it's just so weird of a bug. I tried Googling the issue but I can't find any similar issues.

Thanks for any advice on this...

Reply 1 of 6, by mzry

User metadata
Rank Member

Just wanted to do a quick update on some of this:

New things I tried:
* New harddrive
* New PSU
* New sound card (specifically chose a VIA Envy24 based chip with no hardware acceleration)
* Removed Win2K and installed WinXP SP3 so I can try newer Deus Ex mods
* Re-installed Deus Ex from the GOTY CD I have rather than extracting my GoG version I was previously using
* Used AmigaMerlin's XP drivers for the V5

--- observations ---
None of this helped. Oddly though after re-installing Deus EX from the GOTY CD it went into the save menu and saved (on level1 on the docks) in 640x480, soon as I upped the res to 1024x768 and tried saving it froze on the save screen again!!!
I then installed the Deus EX community mod pack with Trancendance and gave it a try. Of course, I made sure to go into the mod's system folder and delete all the nGlide files, so that it used my systems hardware Glide. Configured to use Glide and Galaxy3D audio. Loaded the game... guess what, it's saving. I start up level 1, on the docks.. save. Change res, try again, saves ok!!!

I am so confused. I'm not counting my chickens yet. I mean, all along this could have been a corrupted installation. But I had previously re-installed from the Gog pack and it didn't help. Also the CD version still crashed on save too. All other games are fine, even Unreal Engine 1 games just like Deus Ex, so it has to be a game specific problem. But it doesn't make sense how I literally played up to the Hong Kong level without any saving issues and then all of a sudden this started happening. None of this makes sense!

I'll start a play-through on this new community modded version with trancendance and see how I go, fingers crossed.

Reply 3 of 6, by mzry

User metadata
Rank Member

I am now convinced this is a motherboard issue... even though I've re-capped it. I did some googling and found mention of the 'TUSL2-C siren crash' which describes this issue well. I have also found that this has started to happen in other games too, not just Deus Ex. I've ordered a cheap replacement motherboard to test.

Google cached copy of the siren crash thread:
https://webcache.googleusercontent.com/search … ent=firefox-b-d

Reply 4 of 6, by dormcat

User metadata
Rank Member
mzry wrote on 2022-05-25, 13:16:

I swap from using my IDE CF Card game drive, copied the game to C:\ which is Adaptec SCSI, still the game locks on save, so it isn't a dodgy CF card...

I had a similar "crash on save" problem on Warcraft II using a CF card as the main drive. Solved by keeping the mouse stationary during saving. Don't know if this info helps but that's my two cents.

Reply 5 of 6, by mzry

User metadata
Rank Member

Just to update this thread: As mentioned in that archived forum I linked to, I managed to find myself another TUSL-2 board, but this time one made in Taiwan! Now I can save in Deus Ex again 😉 Very happy! Who knows what component fails over time on the Chinese made boards, but it's certainly a real issue. I noticed that the Intel chipset on the Taiwan board was made in Malay, where as the Chinese one was made in Korea, just an observation. But from an electronics stand-point, it could be the voltage regulators they use on the board - perhaps the brand quality used isn't as good, there are many of them. Since the issue was reproducable, I can only speculate that going to 'save' in the game triggers the SCSI card (I am using SCSI) to access the disk, perhaps that causes a voltage drain on the PCI bus due to bad regulation and therefore causes a crash - I don't know though, just guessing.