VOGONS


First post, by Warlord

User metadata
Rank l33t
Rank
l33t

I have a voodoo 2 that I believe has bad ram on it. If I limit the amount of texture memory to 2mb there is no graphical glitches in DII. So that makes me think its vram. It wasn't glitching out that I could see in quake 2 I don't know why.

I have a doner card that is dead I can use pull parts from so that is not a problem. This card is flawless in D3d. . How can i figure out which ram it is. Or possibly narrow it down to the ram on one of the TMUs.

Top is default settings. Bottom one is limit texture memory to 2mb.

Attachments

Reply 2 of 10, by Warlord

User metadata
Rank l33t
Rank
l33t

underclocking has no effect, probably should of mentioned that. I'll run some more tests when I wake up later. Give you guys some more information. If anyone knows of any tests I can do that will use 1 or the other TMU let me know. Then atleast I can narrow it down.

Reply 3 of 10, by Warlord

User metadata
Rank l33t
Rank
l33t

Ok I ran some more tests by disabling 1 of the TMUs.

SSTV2_NUM_TMUS =1

Doing so it went from bad to worst. With 2 TMUs in Diablo II the glitches are limited to like rock piles and wagons and some stuff. With only 1 TMU the loading screen glitches out as well as the character in addition to everything before.

That leads me to think that the bad ram or TMU is which ever one doesn't get disabled when you set SSTV2_NUM_TMUS =1

Does anyone have a clue as to which one that should be.

Reply 4 of 10, by weedeewee

User metadata
Rank Oldbie
Rank
Oldbie

With one disabled, I would say, the one that does get hot 😀

Right to repair is fundamental. You own it, you're allowed to fix it.
How To Ask Questions The Smart Way
Do not ask Why !

Reply 5 of 10, by Warlord

User metadata
Rank l33t
Rank
l33t

🤣, in that case its noticeably TMU 0 the left side one.

2nd question. If I limit the texture memory to 2mb is that only using the ram on the front. Because the game wont run with 1 tmu and 2mb but the game does run with 2 tmu and 2mb. With 2 tmu and 2mb it doesn't glitch.

So we narrow it down to TMU 0 and the ram on one of the sides.

I could try another game that will work with only 2mb 1 tmu i guess any suggestions? Then if it doesnt work we know its the front.

Reply 6 of 10, by Warlord

User metadata
Rank l33t
Rank
l33t

I've tried a couple games, GTA which doesn't seem to use the TMU anyways and works fine. Carmagedon which only uses the 1st TMU anyways which glitches and confirms my suspisions of it being that TMU. However I couldn't get it to load with only 2mb of textures. Does anyone know of a game that will only use 2mb? So i can see if its the front or back ram.

GLquake ran fine with 1 tmu and 2 or 4mb...

Reply 7 of 10, by sdz

User metadata
Rank Member
Rank
Member

TMU0 is on the right side of the card. I fixed quite a few V2 cards, and I never found one with faulty RAM. In case of artifacts, almost always the issue was loose pins.
Take a sharp tool (a needle would work fine) and gently poke all the TMU pins, see if they move. Do this for both TMUs.

Reply 8 of 10, by bloodem

User metadata
Rank Oldbie
Rank
Oldbie

It's unclear from the Diablo screenshots if it's the TMU or not, it might very well be related to the FBI chip/memory.
When you run 3D games, do you see texture corruption in 3D space, or do you see random patterns on the screen?

2 x PGA132 / 5 x Socket 3 / 9 x Socket 7 / 12 x SS7 / 1 x Socket 8 / 14 x Slot 1 / 5 x Slot A
5 x Socket 370 / 8 x Socket A / 2 x Socket 478 / 2 x Socket 754 / 3 x Socket 939 / 7 x LGA775 / 1 x LGA1155
Current rig: Ryzen 5 3600X
Backup rig: Core i7 7700k

Reply 9 of 10, by Warlord

User metadata
Rank l33t
Rank
l33t
bloodem wrote on 2021-08-26, 13:54:

It's unclear from the Diablo screenshots if it's the TMU or not, it might very well be related to the FBI chip/memory.
When you run 3D games, do you see texture corruption in 3D space, or do you see random patterns on the screen?

Nope normal d3d rendering the card doesn't have any artifacts. The only 2 games I have found so far to produce artifacts are carmegedon and D II. Neither artifiact if I reduce texture memory to t0 2mb. And they both exibit the same behavior when I limit rendering to only 1 TMU.

If I run 2 TMU and all 2mb memory no artifacts.
If I run 2 TMU and all 8 mb memory small amount of artifacts.
If I run 1 TMU 4mb memory I get more artifacts than with 2 TMU 8 meg.
If I run D3D only or a glide game that isn't using whatever textures like carmegedon or DII there is no artifacts at all.

the only thing will be corrupted in carmegedon is like the cars with all default settings on the voodoo 2 config If you run 1 TMU then its more than just cars that get corrupted. If you run 2 tmu 2mb the game runs fine no corruption.

Reply 10 of 10, by Warlord

User metadata
Rank l33t
Rank
l33t
sdz wrote on 2021-08-26, 13:43:

TMU0 is on the right side of the card. I fixed quite a few V2 cards, and I never found one with faulty RAM. In case of artifacts, almost always the issue was loose pins.
Take a sharp tool (a needle would work fine) and gently poke all the TMU pins, see if they move. Do this for both TMUs.

I've got a digital microscope for smd rework etc and I'll check this out. My immediate reaction is probably not however, since I've had it under the microscope and looked several times. I do know what you're talking about I've fixed 3 voodoos the way you are describing, everything from straitening bent pins to retouching them. This particular voodoo is one that flys under the radar that it might seem to fully work except for a minor issue, that doesn't properly expose itself with all games.

I'm not in any hurry to start de soldering chips off the back of the board and re soldering them. So I definitely check this out some more.

But If I could find a game that will run with 2mg and 1 tmu, it might make it obvious if it is ram or not.